Solucionar la incompatibilidad con las librerías i386 en 64-bit

Los que instalamos Kubuntu para 64-bit, aptitude nos genera automáticamente un problema dependencias con las librerías de 32-bit. Una solución rudimentaria es modificar el archivo /etc/dpkg/dpkg.cfg.d/multiarch agregando el numeral # a la linea foreign-architecture i386. Así no se da cuenta que los paquetes instalado para i386.

Pero para solucionar el problema haremos más práctico:

  1. Ingresamos a aptitude
    sudo aptitude
  2. Presionamos F10
  3. Con el cursor del teclado seleccionamos: «Cancelar acciones pendientes»
  4. Presionamos Enter
  5. Presionamos Q
  6. Con el cursor del teclado seleccionamos: Yes
  7. Presionamos Enter

Cuando vuelvan a utilizar «aptitude -f install» no volverán tener problema con paquetes y/o dependencias rotas.