Recuperar GRUB2 (1.97~beta4) después de instalar Windows

Enviado por shaola el 4 Marzo, 2010 - 16:06.

mmmm, dudo de que este artículo funcione correctamente, si montas la raiz em /mnt/boot, el chroot se debe hacer a /mnt/boot no a /mnt.

El autor del artículo por favor que revise eso y comente algo.

Enviado por allan_CR el 4 Marzo, 2010 - 16:29.

@shaola: Es el procedimiento que seguí, y de hecho lo tengo claramente documentado con un sitio serio.
Aún así, por supuesto que puede haber algo que corregir. Pásate por la fuente y si ves algo que haya interpretado/traducido/indicado de manera equivocada por favor avísame. La guía la hice rato después de que corregí el problema en mi compu, algo puede habérseme pasado por alto.
Gracias.
EDITO. Creo que tienes razón shaola. Ya hice la corrección.

Enviado por shaola el 4 Marzo, 2010 - 16:39.

el error no está en el proceso de reinstalación del grub, sino en la forma de montar las particiones. Tal y como está escrito no funciona, porque tu montas la partición raiz sobre /mnt/boot y luego haces chroot a /mnt. Ni siquiera funcionaría ese chroot.

En el artículo original, se menciona que si tienes una partición a parte para el /boot, después de montar la parttición raiz sobre /mnt, tienes que montar la partición /boot sobre /mnt/boot. Ahí es donde te has equivocado a la hora de redactar el artículo y has mezcaldo cosas.

De todas formas, si al hacer la instalación has particionado a parte la carpeta /boot, significa que sabes lo suficiente como para no tener que leer ese paso para saber que tienes que hacerlo. Luego lo corrijo.

Enviado por shaola el 4 Marzo, 2010 - 16:44.

de hecho, creo que si el objetivo es recuperar el grub y no instalarlo, bastaría con update-grub, pero no estoy seguro del todo.

Enviado por allan_CR el 4 Marzo, 2010 - 17:51.

shaola escribió:

de hecho, creo que si el objetivo es recuperar el grub y no instalarlo, bastaría con update-grub, pero no estoy seguro del todo.

A mi eso no me funcionó. Ahora que tenga más tiempo me pongo a revisar con detalle el proceso.
Gracias shaola.

Enviado por allan_CR el 5 Marzo, 2010 - 13:48.

No es mi intención contradecir, pero como lo indico, es redundante en este caso ejecutar los comandos con sudo luego del chroot. Así mismo lo hice yo; el tutorial está basado en la documentación pero también en mi experiencia personal reciente.
Al ser una redundancia, puede quedar así por el momento.

Enviado por shaola el 5 Marzo, 2010 - 13:51.

allanngccc escribió:

No es mi intención contradecir, pero como lo indico, es redundante en este caso ejecutar los comandos con sudo luego del chroot. Así mismo lo hice yo; el tutorial está basado en la documentación pero también en mi experiencia personal reciente.
Al ser una redundancia, puede quedar así por el momento.

Exacto, al hacer chroot trabajas como root. Así que no es necesario el sudo. hay que revertir el cambio. Ahora voy a comer, luego lo hago.

Enviado por allan_CR el 5 Marzo, 2010 - 13:55.

Tranquilo shaola, yo lo hago.
EDITO. Hecho.

Enviado por Viorel el 5 Marzo, 2010 - 20:00.

Oops. desliz mio, lo siento. Pero hay que cambiar $ por #, por eso la confusión.

Igual creo que con un os-prober y un update-grub debería ser suficiente.

Saludos.

Enviado por allan_CR el 8 Marzo, 2010 - 00:23.

Hmmm creo que puede tener razón Viorel con lo de $ o #, hay que chequear.
Y no, en mi caso no me funcionó con el update-grub.