kde 4.13.2 y locale español

Hola. Lo pongo en el sitio de los bugs porque tiene toda la pinta de serlo.

Tengo instalado kubuntu 14.04 y ayer actualicé a la versión 4.13.3 de KDE desde el ppa "kubuntu updates" (http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu trusty).

Reinicio el entorno gráfico y me lo encuentro todo en inglés (antes lo tenía en castellano).
Entro en systemssetings y en locale -> languages añado"spanish" a la columna de la derecha (preferred languages). Lo subo y le doy a aplicar, apareciendo el siguiente error:

You have the language with code 'es' in your list of languages to use for translation but the localization files for it could not be found. The language has been removed from your configuration. If you want to add it again please install the localization files for it and add the language again.

Y otra vez KDE en inglés.

Voy a la socorrida consola y tecleo un sudo dpkg-reconfigure locales que me arroja lo siguente:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en",
        LC_ALL = (unset),
        LC_PAPER = "en_ES.UTF-8",
        LC_ADDRESS = "en_ES.UTF-8",
        LC_MONETARY = "en_ES.UTF-8",
        LC_NUMERIC = "en_ES.UTF-8",
        LC_TELEPHONE = "en_ES.UTF-8",
        LC_IDENTIFICATION = "en_ES.UTF-8",
        LC_MEASUREMENT = "en_ES.UTF-8",
        LC_TIME = "en_ES.UTF-8",
        LC_NAME = "en_ES.UTF-8",
        LANG = "en_ES.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
  en_AG.UTF-8... up-to-date
  en_AU.UTF-8... up-to-date
  en_BW.UTF-8... up-to-date
  en_CA.UTF-8... up-to-date
  en_DK.UTF-8... up-to-date
  en_GB.UTF-8... up-to-date
  en_HK.UTF-8... up-to-date
  en_IE.UTF-8... up-to-date
  en_IN.UTF-8... up-to-date
  en_NG.UTF-8... up-to-date
  en_NZ.UTF-8... up-to-date
  en_PH.UTF-8... up-to-date
  en_SG.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  en_ZA.UTF-8... up-to-date
  en_ZM.UTF-8... up-to-date
  en_ZW.UTF-8... up-to-date
  es_AR.UTF-8... up-to-date
  es_BO.UTF-8... up-to-date                                                                                                                                                
  es_CL.UTF-8... up-to-date                                                                                                                                                
  es_CO.UTF-8... up-to-date                                                                                                                                                
  es_CR.UTF-8... up-to-date                                                                                                                                                
  es_CU.UTF-8... up-to-date                                                                                                                                                
  es_DO.UTF-8... up-to-date                                                                                                                                                
  es_EC.UTF-8... up-to-date                                                                                                                                                
  es_ES.ISO-8859-1... up-to-date                                                                                                                                           
  es_ES.UTF-8... up-to-date                                                                                                                                                
  es_GT.UTF-8... up-to-date                                                                                                                                                
  es_HN.UTF-8... up-to-date                                                                                                                                                
  es_MX.UTF-8... up-to-date                                                                                                                                                
  es_NI.UTF-8... up-to-date                                                                                                                                                
  es_PA.UTF-8... up-to-date                                                                                                                                                
  es_PE.UTF-8... up-to-date                                                                                                                                                
  es_PR.UTF-8... up-to-date
  es_PY.UTF-8... up-to-date
  es_SV.UTF-8... up-to-date
  es_US.UTF-8... up-to-date
  es_UY.UTF-8... up-to-date
  es_VE.UTF-8... up-to-date
  eu_ES.ISO-8859-1... up-to-date
  eu_ES.UTF-8... up-to-date
  eu_FR.UTF-8... up-to-date
Generation complete.

No se si alguno ha tenido el mismo problema después de actualizar a la versión 4.13.3 de KDE (no encuentro nada por internet) o si es cosa mía (que me extraña, pues no toqué nada a parte de la actualización).
A ver si alguien puede iluminarme un poco.

Gracias y un saludo.

Perdón donde dije KDE 4.13.3 era kde 4.13.2 cheesygrin

Además añadir que tengo instalados los paquetes kde-l18n-es y language-pack-es.

El paquete es kde-l10n-es, no kde-l18n-es.
No publiquéis cosas en Bugs al menos que este contrastado que se trata efectivamente de uno, por favor. Siempre hay tiempo a moverlo aquí cuando se confirme.

Prueba:

sudo locale-gen es_ES.UTF-8

para generar los locales y luego reconfiguralos con

sudo dpkg-reconfigure locales

a ver si se hace algo. Imagino que habrá que reiniciar la sesión.

Perdón por la confusión y por postear donde no era.

Gracias por la sugerencia Ralsa. Ya lo había probado y no funcionó.

¿tienes instalado el paquete locales?

Sí.

A mi me pasó también !!!, tuve que instalar los pquetes del idioma otra vez, luego cambiar el idioma de la aplicación , reiniciar y listo todo en español de nuevo.

Y como te fue con el idioma ?

Pues lo "solucioné" reinstalando. mrgreen mrgreen mrgreen

No daba con la forma de solucionarlo y opté por la última opción.....

Además así tengo instalación limpia de LTS, para no tocar en un tiempo....

Yo romperé una lanza a favor de las conclusiones de ekaitza... Tanto Muon, como buena parte del sistema operativo incluida Konsole descartan otros idiomas que no sean el american english... Sí hay en la red información al respecto del más que posible bug, pero las recetas que se ofrecen no funcionan y continúa el problema. En primer lugar, fui a Sistema/locale y no me dejaba instalar el idioma, que desaparecía cuando le dabas a aplicar y dejaba sin cambiar el american english. Descubrí que había actualizaciones en Muon que no aparecían en Konsole cuando le ordenabas sudo aptitude update && sudo aptitude safe-upgrade. Actualicé con Muon para ver que pasaba, reinicié y entonces pude introducir el idioma, acudiendo a cambiar el país antes que el idioma. Una vez todo en orden, actualicé por Konsole de nuevo y comprobé que existía una anomalía.
Busqué en la red y encontré l solución que tú explicas... sudo locale-gen es_ES.UTF-8 y luego sudo dpkg-reconfigure locales, pero no he tenido éxito... Mi idioma es el catalán, pero nunca he tenido problemas y me dice esto:

perl: warning: Setting locale failed.   
perl: warning: Please check that your locale settings:
        LANGUAGE = "en",
        LC_ALL = (unset),
        LC_TIME = "en_ES.UTF-8",
        LC_MONETARY = "en_ES.UTF-8",
        LC_ADDRESS = "en_ES.UTF-8",
        LC_TELEPHONE = "en_ES.UTF-8",
        LC_NAME = "en_ES.UTF-8",
        LC_MEASUREMENT = "en_ES.UTF-8",
        LC_IDENTIFICATION = "en_ES.UTF-8",
        LC_NUMERIC = "en_ES.UTF-8",
        LC_PAPER = "en_ES.UTF-8",
        LANG = "en_ES.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Considero que puede tratarse de un bug temporal... y yo preferiría solucionarlo sin reinstalar... Últimamente hay algunas actualizaciones que dejan mucho que desear y luego hay que ir parcheando...

Bien... Ha sido rápido, pero concreto... La clave parece estar en ese

perl: warning: Falling back to the standard locale ("C").

Y la solución, al menos por lo que respecta a no encontrar el warning que aporto en mi anterior intervención en Konsole tras actualizar se explica en este hilo:

http://www.becodemyfriend.com/2011/11/perl-warning-falling-back-to-the-standard-locale-c/

Son 5 sencillos pasos:

export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
sudo dpkg-reconfigure locales

No sé si lo llamaréis bug, pero aún he de comprobar si vuelvo a tener en Muon, por ejemplo, el idioma elegido... Reinicio y os digo...