Lanzado Kubuntu 14.04 LTS (Trusty Thar)

Bienvenido a Kubuntu 14.04 LTS, una nueva versión compatible a largo plazo de la marca con el último software de KDE para disfrutar.

Long Term Support significa que se añadirán correcciones de errores y actualizaciones de seguridad durante los próximos 5 años, por lo que puede estar seguro de usar que hasta el año 2019. Las nuevas versiones de KDE Software importante también estarán disponibles a partir de las actualizaciones de Kubuntu y Kubuntu Backports PPA.

http://www.kubuntu.org/news/kubuntu-14.04

Bien, una puntualización. No me salía la noticia de la nueva versión ni a tiros, ni en Muon ni en terminal, sea con apt-get o con aptitude.
Finalmente leí esto al final de las instrucciones de actualización de la página de Kubuntu:

Citar

Some Issues: if Muon Update Manager still doesn't detects the latest version, close it and run the following command in Konsole: sudo update-manager -d which run the Update Manager and it will find the latest Kubuntu version.

(Algunas cuestiones: si Muon Update Manager aún no detecta la versión más reciente, ciérrelo y ejecute el siguiente comando en Konsole: sudo update-manager-d que ejecuta el Administrador de actualizaciones y encontrará la última versión de Kubuntu.)

Curiosamente "update-manager" no está instalado, está update-manager-kde y update-manager-common, con los que no sirve, desde luego el comando. Hay que instalarlo antes (con las depedencias que conlleva y desde ahí entonces sí me aparece la actualización.

Curioso.

Canté victoria rápido:

No se ha podido calcular la actualización

An unresolvable problem occurred while calculating the upgrade.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

Si nada de esto aplica, informe de este error usando la orden «ubuntu-bug ubuntu-release-upgrader-core» en una terminal.

A mí no se me actualiza... buaaaaaahhhhhhhhhhhh cry cry cry cry cry

Edito: Ya la estoy actualizando a la máquina a mi manera...

Comparte ideas, que me hace falta.

Ralsa escribió:

Comparte ideas, que me hace falta.

Mis repositorios antes eran:

deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ precise main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ precise-backports main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ precise-proposed main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ precise-security main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ precise-updates main restricted universe multiverse

Los dejé así:

deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ trusty main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ trusty-backports main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ trusty-proposed main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ trusty-security main restricted universe multiverse
deb http://ftp.ccc.uba.ar/pub/linux/ubuntu/ trusty-updates main restricted universe multiverse

Luego los actualicé:

sudo apt-get update

Por último a actualizar la distro:

sudo apt-get dist-upgrade

Hasta ahora no tuve ningún problemas tras la actualización, lo que sí tuve que modificar la barra de volumen Conky. Me da la sensación que Kontact es mucho más fluido comparado con la versión de Precise.

Una actualización "a la Debian" ¿eh? Puede ser una solución.
Estoy pensando que tengo aplicaciones de terceros desde ppa que aún no han desarrollado repo para 14.04 y no sé si esperar.

No creo que sea lo de los PPA. El actualizador comprueba esas cosas y deshabilita toda fuente de terceros.
¿Has ido a orígenes de softwre para ver si lo tienes bien configurado? Puedes abrirlo desde Muon o lanzando desde Alt+F2 con "software-proper". En la pestaña actualizaciones, en notificarme una versión nueva de Ubuntu, elegir cualquiera de las dos primeras (no elegir "Nunca"). Podrías también probar marcando "actualizaciones aún no publicadas". Luego un "sudo apt-get update". Si había paquetes para actualizar, un "sudo apt-get dist-upgrade", y por las dudas nuevamente "sudo apt-get update". Y al final desde Alt+F2 ejecutar "do-release-upgrade".

Son unos paquetes de Trinity los que la están liando. He intentado purgarlos y no se puede, están bloqueando el directorio /var/cache/apt . Los he tenido que borrar a mano, a lo bestia, para poder desinstalar Trinity. Así he podido iniciar la actualización a mano, pero de todos modos ha finalizado en pifostio con cosas a medio configurar (ni siquiera desinstaló Trinity entero), dependencias rotas y nuevos paquetes bloqueando directorios.
Con la actualización parcial puedo entrar en IceWM para seguir trabajando en ello, pero me está llevando mucho tiempo y me estoy tentando con bajar el disco. mrgreen

Así es, los que somos de experimentar instalando muchas cosas, luego tenemos estos problemas mrgreen

Muchas veces hay paquetes que hemos instalado desde terceros y no son posible desinstalar porque se llevan todo el sistema en dependencias. Toca "desactualizarlos" a una versión de repositorios.

Después desde la terminal ir probando, incluso repetidamente, con "sudo dpkg --configure -a" "sudo aptitude -f install", "sudo aptitude full-upgrade" (prefiero aptitude).