Consumo ram XORG, al conectar 2 pantallas en KUBUNU 13.10

Buenas me viene pasando esto y me parece absolutamente raro, resulta que tengo un tv de 40" en mi cuarto y cuando quiero ver peliculas conecto mi laptop a esta por HDMI, el problema viene que luego de desconectar la laptop para usar la Laptop el consumo de RAM de xorg llega hasta los 300 MB y nunca libera la memoria, tengo que reiniciar, para q el sistema quede estable, les anexo una captura.

http://i922.photobucket.com/albums/ad64/revxfire/instantaacutenea3.png

Y Aqui anexo la informacion de mi sistema: http://paste.desdelinux.net/4951

Saludos

¿Hay que reiniciar? ¿NO basta con cerrar sesión?

No basta con cerrar sesión tengo que reiniciar completamente u.u, el xorg es un proceso critico, tendría que salirme a tty2 y reiniciar las x.

Bueno, es más corto que reiniciar sistema.

Hola F3niX.

Este hilo tiene que servir para todo usuario que luego busque en google, por lo que tenemos que intentar que en este mismo hilo figure como texto la mayor información del sistema que creemos puede estar relacionado al problema, tal como indica la norma 6 del foro:

http://www.kubuntu-es.org/wiki/comenzando/howto-conociendo-sistema-o-com...

Es decir, como esto tiene pinta de estar relacionado con el video y en lugar de dar aquí un lshw completo que sería extenso, solo comienza por listar el hardware de video tal como indica la terminal con la orden que se da para tal fin desde el anterior enlace (Sección video).

También indícanos si tienes añadido algún PPA donde pueda haber paquetes del xorg como xorg edgers, versión del driver de video intel, el reproductor de video que estás utilizando,y de paso si has probado con más de un reproductor. ¿Estás seguro que el consumo del xorg crece al instante de desconectar el tv, y no mientras estas viendo la película?. Dinos si el problema ocurre también con los efectos de escritorio desactivados (Alt+Shift+F12 para desactivarlos al vuelo).
Pega aquí la salida de "xrandr" mientras tienes conectadas las dos pantallas, y también la salida cuando desconectas una. Para pegar ese texto, mira aquí como utilizar la etiqueta código:
http://www.kubuntu-es.org/wiki/comenzando/utilizar-opciones-formato-mens...

Fijate si encuentras errores o mensajes extraños desde el Xorg.0.log

Si no sabes como hacer algo de lo anterior y no lo encuentras buscando en google, pregunta aquí.

Saludos.

Mientras se avanza en dilucidar este problema (los datos que te piden los demás compañeros), creo que reiniciar X sin reiniciar es una buena alternativa, se hace de la siguiente manera:

Ctrl + F1
(Esto abre una sesión en modo consola, ya en la consola)
sudo skill Xorg

Espera un poco, la sesión parpadea y debería mostrarte de nuevo el menu de entrada, regresa a la sesión de consola (Ctrl + Alt + F1 y cierra esa sesión exit ó Ctrl + D y regresa a la sesión gráfica con Ctrl + Alt + F7).

Recuerda que cuando hagas esto tú sesión gráfica se muere por completo, si dejaste algo abierto se puede perder, así que primero graba y cierra lo que tengas funcionando.