Al cerrar la seciòn Kubuntu 13.04 no apaga el laptop. [Solucionado]

Nudver escribió:

GRUB_CMDLINE_LINUX="acpi=off nomodeset"

Esa linea, ¿La habías editado manualmente?

Si no la habías editado manualmente, pues entonces yo suponía mal.

Ahora déjame pensar. Si te hago editar esas lineas y guardar los cambios permanentemente, puede que tengas problemas al iniciar el sistema y después no tenerlo disponible para ingresar al foro para preguntar. Así que veamos si puedes modificar esas lineas al vuelo, para que solo se modifique una vez al ingresar, y no queden guardados los cambios.

Reinicia el sistema, en las entradas para elegir el Kernel en el inicio del GRUB, elige el kernel con el cual iniciar sin presionar la tecla Enter, solo posandote sobre el mismo. Allí presiona la tecla "E". Verás algunas lineas, y una de ella como la que ya habías puesto aquí:

linux   /boot/vmlinuz-3.11.0-031100-generic root=UUID=bacfb956-1b85-4949-aeae-87fdefc0b66c ro acpi=off nomodeset  quiet splash $vt_handoff

Pues moviéndote con las flechas del teclado, baja hasta esa linea y quita el "acpi=off" y el "nomodeset", dejando esa linea así:

linux   /boot/vmlinuz-3.11.0-031100-generic root=UUID=bacfb956-1b85-4949-aeae-87fdefc0b66c ro quiet splash $vt_handoff

No presiones la tecla Enter nunca. Presiona la tecla F10 para iniciar con esas modificaciones. Si el sistema inicia correctamente, fijate si tienes disponibles las opciones de energía en Kubuntu, y si la pantalla se apaga al apagar el sistema.

Luego si funciona, veremos como hacer los cambios permanentes.

PD: La atención que recibes es la misma que recibiría cualquier usuario que cumpla con las normas del foro. Lo que ocurre es que es poco frecuente que se cumplan con las normas.

Estimado YAFU... tengo una emoción que no entro en mi.-
Te diré que tu último Post, dio con la solución en forma transitoria...
Paso a detallar.
Una vez cumplido el reinicio del sistema y ya en el cartel de Grub, seleccioné la primera opción y continué ejecutando todos los pasos que me indicaste muy despacio encomendándome a San Expedito y a toda la patota de compañeros que siempre nos resguardan...jejeje, (pavada de amigos que me hice...¿No?)...
Una vez presionada la tecla F10, todo comenzó a rodar como siempre sin dar ningún indicio de que hubiese algo mal...
Cuando apareció el escritorio de Kubuntu me puse muy contento y te saque una foto con el celu para que veas que con ese comando se solucionó todo...
Foto con el monitor de batería activado y todo lo correspondiente al gesstor de energía funcionando

eek

Como no podía ser de otra forma, también la pantalla se apagó al dar la orden correspondiente...

como verás la edición de esa línea llevó a la normalidad mi Kubuntu ahora 13.10....
Por último te diré que yo no edité anteriormete esa línea ni sabía ¿como editar los comandos del gestor de inicio Grub.-
Lo que te decía en el tráfico anterior era que en la instalación había tildado la opción ACPI=OFF porque la instalación se trancaba después del formateo de las particiones del disco y alguien me indicó que debía tildar esa opción en los comandos de instalación.-
Bueno estimadísimo, quedo a la espera de nuevas instrucciones para continuar con esta MISION IMPOSIBLE...que si los descubre el enemigo....bla,bla....
Por todo tu tiempo y detalle en las indicaciones te agradezco infinitamente.-

confused

Bien, ahora resta hacer los cambios permanentes como te había dicho.
Haz un backup del archivo "/etc/default/grub" de la siguiente forma:

sudo cp /etc/default/grub /etc/default/grub_bkp

Luego abre ese archivo para editarlo con kate y como superusuario:

kdesudo kate /etc/default/grub

encuentra la linea que antes habías pegado aquí:

GRUB_CMDLINE_LINUX="acpi=off nomodeset"

y edítala dejándola así:

GRUB_CMDLINE_LINUX=""

guarda los cambios del archivo, y cerrarlo.

Luego actualiza la configuración del GRUB con:

sudo update-grub2

Espera a que termine de hacer su trabajo desde la terminal, reinicia el sistema y comprueba que todo esté en orden.
Saludos.

Estimado YAFU....
Bueno, realmente cuando sea grande quiero ser la mitad de lo que tu eres...
Realmente ahora tengo el gestor de energía funcionando correctamente y se puede ver el estado de la batería además de poderse apagar la pantalla con la orden correspondiente.-
Habrían dos consultas más sobre le mismo tema...
1) Si tengo que formatear por causas fortuitas, deberé marcar nuevamente el ACPI=off y posteriormente hacer todo este trámite?.-
2)¿Qué libro o tutorial me recomiendas para que comience a estudiar sobre estos temas, como ser comandos de Kubuntu, estructura del sistema,(es decir que hay en cada carpeta del sistema lo que sea que me permita aprender sobre este sistema?...
Desde ya Estimadisimo te agradezco infinitamente que me ayudaras con este caso que si bien no era grave, jodía bastante dado que si uno se olvidaba de apagar el laptop con el botón, quedaba encendido.-
Bueno Yafu voy a esperar tu comentario a mis requerimientos anteriores y posteriormente voy a dar por finalizado el hijo....
MUCHAS GRACIAS....

Bien Nudver!

1)Seguramente si, si utilizas nuevamente la misma versión que había dado problemas. Habría que ver si con el DVD/LiveUSB de la versión 13.10 sigue estando presente el problema.

2)Yo libros no he utilizado para aprender sobre Linux. Solo siendo un usuario de muchos años, leyendo foros y wikis. Nada más.

Tampoco es que todo esto que te he dicho a lo largo de este hilo yo me lo sepa de memoria. Yo se mas o menos lo que debe hacerse, pero muchas veces las órdenes, comandos o ruta de archivos debo buscarlos para recordar como eran exactamente.

Saludos.

Desde ya muchas gracias por tu gestión y toda la ayuda que nos das...