No se levanta el entorno gráfico tras instalar, pero sí en el live-cd, en 13.04 [Solucionado]

Hola a todos!

Tengo problemas con el video en Kubuntu 13.04. El live arranca y se ejecuta estupendamente (y procedo a instalar desde él).
Pero, una vez instalado el sistema, las X no llegan a levantarse y se produce un cuelgue del video (la pantalla queda en negro, las tty no responden ni se muestran), sin embargo el sistema "aparentemente" sigue funcionando (responde a ctrl + alt + supr y reinicia el sistema o lo apaga si pulso el botón de apagado).

He probado la instalación limpia y tengo este problema, el que persiste si instalo todas las actualizaciones.
La única manera de que funcione es usando la opción "nomodeset" en el grub, pero esto hace que se desactiven las tty y la resolución de video es muy baja (la que no puedo cambiar porque la opción en preferencias del sistema no detecta más resoluciones, y tampoco puedo usar xrandr porque necesito primero matar las X y hacerlo desde alguna tty pero se deshabilitan con nomodeset).

El equipo es un laptop con cpu amd y chip de video ati hd 4200. No tengo estos problemas con otras distribuciones. La imagen de instalación no está corrupta (comprobé md5). Tengo el controlador libre radeon.

He buscado información pero ninguna se acerca al problema (o no he sabido buscar). Llevo intentando usar Kubuntu ya una semana y no se me ocurren más opciones para probar.

Por cierto, si hago un arranque normal, antes del cuelgue del sistema de video (y es lo único), aparecen los siguientes mensajes en la tty 1:

radeon 0000:01:05.0: gpu lockup CP stall for more than 1000msec
[drm:r600_ring_test] *ERROR* radeon: ring 0 test failed (scratch (0x8504)=0xCAFEDEAD)
[drm:r600:resume] *ERROR* r600 startup failed on resume

Ojalá puedan darme algunas pistas para solucionar el problema.

El tema está perfectamente expuesto en el cuerpo del post, por lo que esta vez he considerado la flexibilidad y no cerrar el hilo, pero por favor, lee atentamente este enlace y tenlo en cuenta a la hora de publicar en lo sucesivo respecto a los títulos:

http://www.kubuntu-es.org/foro/201209/hilos-que-no-cumplan-normas-priori

Es para mayor orden y limpieza en el foro.

Muchas gracias.

Hola.
Ya se que has dicho que es una ATI hd 4200. Pero aquí siempre recomendamos indicar el hardware tal cual lo reconoce el sistema. Lee el siguiente enlace, la primer orden de la sección video:
http://www.kubuntu-es.org/wiki/comenzando/howto-conociendo-sistema-o-com...

También recomendamos utilizar versiones LTS de Kubuntu, es decir actualmente la 12.04.3

He buscado con ese mensaje de error y hay reportes, no se si alguno exactamente para tu caso.

¿Has intentado configurar un xorg.conf?
No olvides analizar el xorg.0.log y el kern.log en busca de más datos.

También podrías ingresar con nomodeset, y añadir el repositorio de Xorg Edgers, que es un repositorio inestable pero para estos casos puede ser útil:
https://launchpad.net/~xorg-edgers/+archive/ppa

Luego de añadirlo, "update" y "upgrade". Si el sistema inicia al reiniciar, deshabilitar ese repositorio.
También un Kernel más nuevo sería recomendable:
http://kernel.ubuntu.com/~kernel-ppa/mainline/

Saludos.

Ralsa,

Gracias por considerar no cerrar el cierre de mi caso. He leído las normas y he intentado ser lo más descriptivo y genérico en el título para llamar la atención respecto de lo me ocurre, no fue descuido o desinterés (mi intención era indicar los síntomas del problema, para que cualquier otro que tenga un problema similar pueda encontrarlo).

Leí el enlace sobre la discución sobre el cierre de hilos. Estoy completamente de acuerdo en ello, hay muchos temas que no son encausados correctamente por los usuarios, colaboradores y moderadores que con el tiempo llegan a hundir la información útil entre discuciones que muchas veces son lo mismo (y se dificulta encontrar la solución adecuada a algo que ya ha sido respondido). Después de leer la discución concuerdo en que el título pudo ser mucho mejor. Intentaré no incurrir en ello en el futuro.

Se trata de no incluir "problema con..." (o cosas por el estilo) en el título, que no aportan ninguna información.

Respecto al tema, aparte de lo dicho por Yafu... ¿Hay controlador de ATI que hayas probado?

Yafu,

Muchas gracias por tus recomendaciones.

La salida de lspci es:
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series]

También he buscado información, la más cercana a una posible solución es https://bugs.freedesktop.org/show_bug.cgi?id=64072
es de abril de 2013 y está relacionado con Ubuntu. En los comentarios se señala que el problema se salva instalando un núcleo Linux 3.99 (o superior). Es una opción, como comentas, pero no quiero estar lidiando con diferentes repositorios.

El kernel log arroja como error las líneas que he indicado.

Creo que en mi caso tengo dos opciones: LTS o esperar a la 13.10. Voy a probar la LTS de momento y ya veré con 13. 10 llegado el momento (no me atrevo con la beta).

Lo que no me acaba de cuajar es cómo el live funciona sin problemas, he revisado la línea de arranque y no noto nada especial.

En fin, probaré la LTS y si no hay problemas doy el caso como solucionado si es que no surgen problemas.

Gracias a ambos por la atención prestada.

Ralsa escribió:

Se trata de no incluir "problema con..." (o cosas por el estilo) en el título, que no aportan ninguna información.

Respecto al tema, aparte de lo dicho por Yafu... ¿Hay controlador de ATI que hayas probado?

Si te refieres al privativo, no. Como es un modelo de tarjeta "obsoleta" según AMD, pues no puedo usar los controladores privativos (a estas fechas, ya es un cuelgue seguro en casi cualquier distribución). La instalación es "limpia". Probaré la LTS a ver que tal se porta (debería no tener problemas, espero).

Puedes probar

Citar

sudo aptitude install xserver-xorg-video-ati

He probado con xserver-xorg-video-ati y con xserver-xorg-video-radeon, pero el sistema dice que están instalados.

lelo escribió:

He probado con xserver-xorg-video-ati y con xserver-xorg-video-radeon, pero el sistema dice que están instalados.

ninguno de esos es el privativo. hace mucho que no uso ubuntu, pero busca fglrx-driver, yo diría que es ese.

Fgrlx efectivamente es el privativo, pero no es instalable en mi caso (el programa de controladores adicionales no lo ofrece, supongo que verifica la versión de Xorg y el modelo de tarjeta para ofrecer o no el controlador privativo).

Acabo de instalar la versión LTS. El modo live se veía "bastante normal" (el live de 13.04 entregaba una imagen más nítida). Lo he instalado y actualizado y la calidad de imagen ahora es la misma que la de 13.04. Como menciono más arriba, el problema debe estar... en alguna parte entre los controladores o el núcleo, lo curioso en que en el modo live el problema no se expresa en absoluto. En fin, que creo que LTS es la solución con la que me conformaré (el próximo mes veremos que tan estable viene 13.10).

Gracias a todos por su ayuda, espero poder retribuir de alguna forma la atenciń recibida.