Problema con wiki [Cerrado]

Hola gente. Espero que este sea el lugar adecuado para plantear el problema que estoy teniendo. Uso Kubuntu 12.10

El problema:
No logro conectarme a internet mediante wifi. La red anda bien ya que desde otros equipos se conecta bien. Se queda esperando autorización. Estos es, las redes las reconoce, me pide la contraseña y depués no avanza... dice "Waiting authorization". Con cable de red se conecta perfecto.

Información:
Cuando veo la configuración de la red desde otra pc (con Windows) dice que usa clave WPA Personal. Por lo tanto la configuración que puse en Manage Connections es WPA/WPA2 Personal
lspci

03:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
06:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             disconnected
  Default:           no
  HW Address:        00:26:5E:46:DE:D4

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points
    Telefonik:       Infra, 94:0C:6D:C7:C6:58, Freq 2412 MHz, Rate 54 Mb/s, Strength 44
    Lusarreta1:      Infra, D4:D1:84:33:5F:A8, Freq 2437 MHz, Rate 54 Mb/s, Strength 32 WPA

En Aplicaciones > System > Aditional Drivers dice No propietary drivers are in use on this system, y todo esta vacío.

Lo que probé:
En realidad no es mucho. Todo lo referido que enontré en google no lo solucionó.
Probé eliminando la conexión desde Manage Connections, reiniciando el servicio y volviendo a abrir la conexión.
Traté de econtrar algún driver pero nada.

Es mi primer post. Hace dos días que ví por primera vez un SO que no sea Windows, asique si alguien puede ayudarme, por favor no de nada por entendido. Cualquier otra información que necesiten la daré.

http://www.kubuntu-es.org/foro/201209/hilos-que-no-cumplan-normas-priori

http://www.kubuntu-es.org/normas-foro#4

Por favor, lees estos enlaces, luego pásate por las normas del foro en general, revísalas bien y vuelves a abrir el hilo correctamente.

Muchas gracias.