Kubuntu dañado luego de update

trapichepiche escribió:

Otra cosa que note es que a veces kde no arranca automáticamente (a veces!) queda el prompt para hacer login....

¿Usas una Nvidia? Porque KDM está dando guerra con las NVidia con los drivers propietarios últimamente en Precise.

Apague todas las "fuentes" extras....

nrique@martillo-linux:~$ sudo aptitude install -f
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0 B de archivos. Después de desempaquetar se usarán 0 B.
                                                
enrique@martillo-linux:~$ sudo aptitude full-upgrade
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0 B de archivos. Después de desempaquetar se usarán 0 B.

y si uso una placa nvidia (funcionaba perfecto antes del "upgrade")

NOTA: acabo de darme cuenta que el gestor de "controladores adicionales" dice "No hay controladores privativos activos en este sistema"

pero tengo esto:

enrique@martillo-linux:~$ lspci | grep -i vga
01:00.0 VGA compatible controller: NVIDIA Corporation NV44 [GeForce 7100 GS] (rev a1)
enrique@martillo-linux:~$
trapichepiche escribió:

gracias por la idea..pero no funciono...

enrique@martillo-linux:~$ sudo aptitude reinstall kubutu-desktop -f
[sudo] password for enrique:
Sorry, try again.
[sudo] password for enrique:
No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «kubutu-desktop»
No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «kubutu-desktop»
No se instalará, actualizará o eliminará ningún paquete.

¡¡Atención ERROR!!
No deberías hacer copypastes. Si hubieras tecleado lo que te escribí te hubieras percatado del error que tuve (me culpa) al postear la orden. El paquete kubutu-desktop no existe, claro, porque es kubuntu-desktop, lógicamente.
Prueba a ver otra vez.

trapichepiche escribió:

gracias por la idea..pero no funciono...

enrique@martillo-linux:~$ sudo aptitude reinstall kubutu-desktop -f
[sudo] password for enrique:
Sorry, try again.
[sudo] password for enrique:
No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «kubutu-desktop»
No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con «kubutu-desktop»
No se instalará, actualizará o eliminará ningún paquete.

¡¡Atención ERROR!!
No deberías hacer copypastes. Si hubieras tecleado lo que te escribí te hubieras percatado del error que tuve (me culpa, disculpas) al postear la orden. El paquete kubutu-desktop no existe, claro, porque es kubuntu-desktop, lógicamente.
Prueba a ver otra vez.

Mira a ver si quitando kdm e instalando lightdm solucionas lo del inicio de sesión.

sudo aptitude install lightdm lightdm-kde-greeter

Ralsa escribió:

claro, porque es kubuntu-desktop, lógicamente.
Prueba a ver otra vez.

No funciono....

enrique@martillo-linux:~$ sudo aptitude reinstall kubuntu-desktop -f
Se REINSTALARÁN los siguientes paquetes:        
  kubuntu-desktop
0 paquetes actualizados, 0 nuevos instalados, 1 reinstalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0 B/4.254 B de archivos. Después de desempaquetar se usarán 0 B.
(Leyendo la base de datos ... 382702 ficheros o directorios instalados actualmente.)
Preparando para reemplazar kubuntu-desktop 1.254 (usando .../kubuntu-desktop_1.254_i386.deb) ...
Desempaquetando el reemplazo de kubuntu-desktop ...
Configurando kubuntu-desktop (1.254) ...
                                             

probé arrancar con lightdm y se quedo sin arrancar...(se queda en el login: introduzco el pass y se queda alli no mas)

Pues a mí me pasaba lo mismo. KDM no me aparecía al inicio y con Lightdm se me quedaba colgado el arranque. En lo personal no tenía tiempo ni ganas de peleas, y como a mi ver una LTS ha de ser lo primero "estable", sin esta cualidad no me sirve y he actualizado a Quantal y tan feliz.
Lamento no poder ayudar más, pero esto cada vez tiene más que ver con Nvidia. Prueba con en driver privativo a ver.

A mi me pasó algo parecido después de un reinicio.

Prueba a borrar la carpeta .kde del home (activa primero mostrar archivos ocultos en el navegador una vez estés en el home).
Así volverás a la configuración por defecto del Plasma. (haz una copia de respaldo por si las moscas).

Para probarlo si no tienes acceso al escritorio, desde consola, o con el escritorio en negro pulsa alt+F2, para poder lanzar dolphin (teclea dolphin y pulsa intro)

Suerte!