Fallo en la instalacion de adobe air

Hola a todos;
Llevo dias intentando instalar adobe air en kubuntu 12.04 pero cuando voy a ejecutar la aplicacion me aparece la ventana de adobe acepto las condiciones y a continuacion me da el siguiente fallo ;

Error al instalar Adobe AIR. Puede que el administrador no permita la instalación. Póngase en contacto con el administrador.

tras esto decido ejecutar adobe air como superusuario con el siguiente error

No protocol specified
No protocol specified

(/tmp/air.IN9xEX/setup:3148): Gtk-WARNING **: cannot open display:

Me encuentro un poco eclipsado ya que todo lo que encuentro es exactamente lo mismo y reflejan una instalacion sencilla ; y yo el unico problema que he tenido es al realizar ;

arrubioa29@Kubuntu:~$ sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
[sudo] password for arrubioa29:
ln: fallo al crear el enlace simbólico «/usr/lib/libgnome-keyring.so.0.2.0»: El archivo ya existe

y lo mismo con el otro archivo , pero lo he hecho tantas veces que supongo que sera normal.
Gracias por vuestra atencion

¿Como lo instalaste?
¿Para qué el enlace simbólico del gnome keyring?

¿Tu kubuntu es de 32 ó 64 bits? ya que para 64 bits necesitas unas librerias de 32 bits para poderse instalar.

Lo instale tal y como viene en todos los tutoriales pero para que lo veais encuanto tenga acceso al ordenador os pongo el proceso.
Por cierto no medi cuenta de mencionar que es un kubuntu de 64 bit
Tambien puede ser que yo me equivocase ya que casi todos los tutoriales son para ubuntu

Si vale para Ubuntu vale para kubuntu, eso seguro. Me da que Adobe Air no debe de tener nada que ver con el escritorio que uses.

Como os dije ayer aqui os dejo todo el proceso , como vereis tras empezarme a irritarme comence a ser repetitivo.

sudo ./ adobe*.bin
sudo chmod +x AdobeAIRInstaller.bin
sudo ./ AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
sudo  chmod 755 AdobeAIRInstaller.bin
./AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
AdobeAIRInstaller.bin
chmod +x AdobeAIRInstaller.bin
./AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install flashplugin-installer acroread
sudo chmod + x AdobeAIRInstaller.bin
chmod +x AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome- keyring.so.0.2.0 / usr/lib/libgnome-keyring.so.0.2.0
sudo dpkg -i getlibs-all.deb
sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
sudo getlibs -l libhal-storage.so.1
sudo get-install getlibs-all.deb
sudo apt-get getlibs-all.deb
sudo apt-get install getlibs-all.deb
sudo apt-get install libhal-storage1 libgnome-keyring0 lib32nss-mdns
getlibs sudo-l-libhal storage.so.1
getlibs sudo-l libgnome-keyring.so.0.1.1
getlibs sudo-l libgnome-keyring.so.0.2.0
sudo ln-s / usr/lib/i386-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0
chmod + x. / AdobeAIRInstaller.bin
sudo. / AdobeAIRInstaller.bin
sudo . / AdobeAIRInstaller.bin
sudo ./ AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
chmod + x AdobeAIRInstaller.bin
chmod + x. AdobeAIRInstaller.bin
chmod + x. /AdobeAIRInstaller.bin
chmod + x AdobeAIRInstaller.bin
chmod + x. / AdobeAIRInstaller.bin
sudo chmod + x. / AdobeAIRInstaller.bin
sudo chmod + x AdobeAIRInstaller.bin
sudo chmod + x. / AdobeAIRInstaller.bin
chmod + x. / AdobeAIRInstaller.bin
sudo su
sudo ./AdobeAIRInstaller.bin
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
sudo ./AdobeAIRInstaller.bin
sudo chmod +x AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
sudo apt-add-repository “deb http://archive.canonical.com/ $(lsb_release -sc) partner”
sudo apt-get update
sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome- keyring.so.0.2.0 / usr/lib/libgnome-keyring.so.0.2.0
sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
apt-get update
sudo apt-get update
sudo apt-get upgrade
sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome- keyring.so.0.2.0 / usr/lib/libgnome-keyring.so.0.2.0
sudo ln -s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0sudo ln-s / usr/lib/x86_64-linux-gnu/libgnome- keyring.so.0.2.0 / usr/lib/libgnome-keyring.so.0.2.0
sudo ln -s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0sudo ln -s / usr/lib/x86_64-linux-gnu/libgnome- keyring.so.0.2.0 / usr/lib/libgnome-keyring.so.0.2.0
sudo ln -s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0 sudo ln -s / usr/lib/x86_64-linux-gnu/libgnome- keyring.so.0.2.0 / usr/lib/libgnome-keyring.so.0.2.0
sudo ln -s / usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
sudo ./AdobeAIRInstaller.bin
sudo apt-get update && sudo apt-get install flashplugin-installer acroread
sudo ./AdobeAIRInstaller.bin
sudo su
sudo ./AdobeAIRInstaller.bin
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0


pero el resultado final es este;
fallo tras aceptar

Necesilo instalar adobe air para poder correr fotoalbundigital , ya que yo usaba Hofmann pero al pasarme a kubuntu solo lo puedo virtualizar y es una autentica porqueria la virtualizacion , puesta que trabajas con miles de fotos y tarda una barbaridad en cargarlas y en otras carpetas tienes cientos y probe dandole memoria aumentando disco duro y NO VALE .Me he llegado a poner en contacto con hoffman para que saque una version para linux ya que somos muchos con el mismo problema

¿Instalaste las librerías getlibs? ya que Adobe dejó de dar soporte necesitas instalar las librerías de 32 Bits que son necesarias para que funcione.

En el anterior comentario os puse el proceso pero os copio esa parte

sudo apt-get install getlibs-all.deb
sudo apt-get install libhal-storage1 libgnome-keyring0 lib32nss-mdns
getlibs sudo-l-libhal storage.so.1
getlibs sudo-l libgnome-keyring.so.0.1.1
getlibs sudo-l libgnome-keyring.so.0.2.0
sudo ln-s / usr/lib/i386-linux-gnu/libgnome-keyring.so.0 / usr/lib/libgnome-keyring.so.0

he encontrado otro metodo en esta direccion http://elsoftwarelibre.wordpress.com/2011/03/03/instalar-adobe-air-en-ub... pero no encuentro el .deb por lo que no puedo llevarlo acabo

No lo encontrarás porque Adobe habrá retirado el soporte para Linux, imagino.

Así es, adobe retiro el soporte, pero hay algunos lugares de donde se pueden descargar, de aquí yo los descargue hace tiempo, a ver si te sirve.

Gracias por tu aporte pero es exactamente el proceso que he seguido . No obstante lo he repetido como viene en el vinculo con el mismo resultado . ¿ Puede ser este el problema ?:

sudo ln-s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
[sudo] password for arrubioa29:
sudo: ln-s: orden no encontrada
arrubioa29@Kubuntu:~$ sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
ln: fallo al crear el enlace simbólico «/usr/lib/libgnome-keyring.so.0»: El archivo ya existe
arrubioa29@Kubuntu:~$