En la pantalla de selección " instalar o utilizar live" se reinicia el pc al elegir opción

Intenta leer los logs del sistema para encontrar algún mensaje de error o advertencia, en "/var/log/" los archivos "dmesg" y "Xorg.0.log".
Intenta escribiendo al lado de "noacpi" y separada por un espacio la palabra "nomodeset"

Hay que analizar esos archivos del log, para no andar adivinando.

¿Has comprobado la suma md5sum del disco?

bueno estas son las lineas de código donde me aparece error, warning o failed
dmesg:

[ 18.414039] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro

[ 0.790523] ACPI Warning: For \_PR_.P001._PSS: SubPackage[1,2] - suspicious power dissipation values (20110623/nsrepair2-588)
[ 0.790677] ACPI Warning: For \_PR_.P002._PSS: SubPackage[1,2] - suspicious power dissipation values (20110623/nsrepair2-588)

Xorg.0.log:
[ 19.121] (WW) Warning, couldn't open module nv
[ 19.122] (WW) Warning, couldn't open module nv
[ 19.122] (II) Failed to load module "nvidia" (already loaded, -1216691957)
[ 19.122] (EE) Failed to load module "nv" (module does not exist, 0)
[ 19.123] (II) Failed to load module "vesa" (already loaded, 0)
[ 19.123] (II) Failed to load module "fbdev" (already loaded, 0)
[ 19.121] (EE) Failed to load module "nv" (module does not exist, 0)

he leído un rato y parece ser problemas con la tarjeta de vídeo estoy bajando los driver de vídeo de linux para ver que pasa pero si es otra cosa me avisan

no funciono se sigue reiniciando, intente quitarle la tarjeta y igual se sigue reiniciando

¿Has intentado iniciar con "nomodeset"?
Esos mensajes de los drivers de video suelen ser normales. Igual si el sistema te da tiempo antes de reiniciarse, intenta con los drivers privativos "nvidia". Los puedes instalar desde Sistema > Controladores adicionales, estando conectado a internet.