No puedo actualizar: dependencias rotas tras un error en la actualización

buenas tardes, tengo un problema con mi ordenador.
ocurrio un error en la actualizacion por lo que no me deja ahora actualizarlo ni instalar programas.
he probato todo apt-get -f install, sudo apt-get install gksu,y me dice que tengo dependencias rotas. no se que hacer aqui os dejo el codigo.
gracias

Los siguientes paquetes tienen dependencias incumplidas:
gksu : Depende: libgksu2-0 (>= 2.0.8) pero no va a instalarse
glib-networking : Rompe: glib-networking:i386 (!= 2.32.1-1ubuntu1) pero 2.32.1-1 va a ser instalado
glib-networking:i386 : Depende: glib-networking-common:i386 (= 2.32.1-1)
                        Rompe: glib-networking (!= 2.32.1-1) pero 2.32.1-1ubuntu1 va a ser instalado
libqt4-designer : Rompe: libqt4-designer:i386 (!= 4:4.8.1-0ubuntu4.2) pero 4:4.8.1-0ubuntu4 va a ser instalado
libqt4-designer:i386 : Depende: libqt4-script:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                        Depende: libqt4-xml:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                        Depende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                        Depende: libqtgui4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                        Rompe: libqt4-designer (!= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
libqt4-help : Depende: libqt4-network (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
               Depende: libqt4-sql (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
               Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
               Depende: libqtgui4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
libqt4-opengl : Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                 Depende: libqtgui4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                 Rompe: libqt4-opengl:i386 (!= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4 va a ser instalado
libqt4-opengl:i386 : Depende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                      Depende: libqtgui4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                      Rompe: libqt4-opengl (!= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.1 va a ser instalado
libqt4-qt3support : Depende: libqt4-designer (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                     Depende: libqt4-network (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                     Depende: libqt4-sql (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                     Depende: libqt4-xml (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                     Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                     Depende: libqtgui4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                     Rompe: libqt4-qt3support:i386 (!= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4 va a ser instalado
libqt4-qt3support:i386 : Depende: libqt4-network:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                          Depende: libqt4-sql:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                          Depende: libqt4-xml:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                          Depende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                          Depende: libqtgui4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                          Rompe: libqt4-qt3support (!= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.1 va a ser instalado
libqt4-scripttools : Depende: libqt4-script (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                      Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                      Depende: libqtgui4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                      Rompe: libqt4-scripttools:i386 (!= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4 va a ser instalado
libqt4-scripttools:i386 : Depende: libqt4-script:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                           Depende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                           Depende: libqtgui4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                           Rompe: libqt4-scripttools (!= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.1 va a ser instalado
libqt4-sql-mysql : Depende: libqt4-sql (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                    Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                    Rompe: libqt4-sql-mysql:i386 (!= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4 va a ser instalado
libqt4-sql-mysql:i386 : Depende: libqt4-sql:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                         Depende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                         Rompe: libqt4-sql-mysql (!= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.1 va a ser instalado
libqt4-sql-sqlite : Depende: libqt4-sql (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                     Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
libqt4-svg : Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
              Depende: libqtgui4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
              Rompe: libqt4-svg:i386 (!= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4 va a ser instalado
libqt4-svg:i386 : Depende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                   Depende: libqtgui4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                   Rompe: libqt4-svg (!= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.1 va a ser instalado
libqt4-test : Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
               Rompe: libqt4-test:i386 (!= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4 va a ser instalado
libqt4-test:i386 : Depende: libqtcore4:i386 (= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
                    Rompe: libqt4-test (!= 4:4.8.1-0ubuntu4) pero 4:4.8.1-0ubuntu4.1 va a ser instalado
qdbus : Depende: libqt4-dbus (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
         Depende: libqt4-xml (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
         Depende: libqtcore4 (= 4:4.8.1-0ubuntu4.1) pero 4:4.8.1-0ubuntu4.2 va a ser instalado
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).
jorge@jorge-HP-620:~$ apt-get autoremove
E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»

La próxima vez que pegues mensajes de consola o de código, por favor, usa el botón ".c" de la barra de edición de comentarios y te aparecerá como te he editado. Gracias.

Otra cosa que te agradeceremos es que te pases por las normas (que ya has dicho aceptar al registrarte) para escribir apropiadamente títulos de hilos. (aunque este no estaba tan mal) y buscar información en el buscador del foro http://www.kubuntu-es.org/busqueda?cref=http%3A%2F%2Fwww.kubuntu-es.org%... (y de Google).

Si usas Kubuntu no deberías usar gksu para nada, sino kdesudo.

Prueba:

sudo dpkg --configure -a

Luego reinicia la sesión y escribe

sudo aptitude update (vale con apt-get)

Para reactualizar la lista de paquetes de los repositorios y después:

sudo aptitude install -f (o apt-get -f install)

Por aquí preferimos usar aptitude. Lee el manual del uso de aptitude en la wiki. Si no tienes instalado aptitude ponlo con:

sudo apt-get install aptitude

Tu problema también se relaciona con permisos, eso lo resuelve "sudo". He visto tu seguimiento y en este caso y en el pasado que posteaste no pusiste el "sudo".

Hay ciertas aplicaciones de Kubuntu que requeren de privilegios de administrador como apt-get o aptitude para eso es "sudo".

Aunque también puede que esté diciendo cosas que ya sabes, en fin.

Saludos.

Si no hubiera usado sudo la consola simplemente le avisaría de que no es administrador y no pude proceder, no le tiraría dependencias rotas, no creo que sea el caso.

Me atreví a comentar lo de sudo al ver esta instrucción

sam escribió:
jorge@jorge-HP-620:~$ apt-get autoremove
E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»

Es evidente, almenos para mi, que lo que tu (Ralsa) escribes es la solución.

Eso lo dirá Sam. mrgreen

¿Qué error te tiró apt-get -f install?

Buenos dias, y mis mas sinceras disculpas.
he realizado el comando de
"sudo dpkg --configure -a" y al final me ha puesto " proceso detenido por demasiados errores". aun asi continue y reinicie el ordenador.

entonces he echo

jorge@jorge-HP-620:~$ sudo apt-get update

y
me ha dado como resultado

E: Internal Error, No file name for libqt4-designer
E: Sub-process /usr/bin/dpkg returned an error code (1)

tambien

sudo apt-get -f install

da el mismo error
espero comentarios, Gracias.

respuesta a tu pregunta sobre "sudo aptitude update"

jorge@jorge-HP-620:~$ sudo aptitude update
[sudo] password for jorge:
sudo: aptitude: orden no encontrada

Ná, edité la pregunta porque vi luego que ya la habías contestado pero con apt-get.

Te tira ese mensaje porque no tienes instalado aptitude, pero si actualizaste la lista con apt-get es lo mismo.

¿Puedes postear tus repositorios?