vlc no emite audio [Solucionado]

Hace poco mi kubuntu actualizo 53 psquetes, desde entonses vlc no emite audio, tampoco lo hace smplayer
mi targeta de sonido es una HDA ATI SB
Ademas de que por algun motivo y razon hay un codec de video aparece asi


Hola.
¿Qué es lo que has encontrado al buscar (en el foro, google) sobre ese problema, y sobre el mensaje de error?

Por favor, relee las normas del foro para que comprendas cual es el objetivo del mismo:
http://www.kubuntu-es.org/normas-foro

Si tu pegas capturas de pantalla, luego ese texto de las imágenes (como el del mensaje de error) no será tenido en cuenta en los buscadores, y otros usuarios no podrán encontrar hilos con problemas similares. Por eso siempre transcribe o copia las salidas en forma de texto. Lo mismo para el hardware:
http://www.kubuntu-es.org/wiki/comenzando/howto-conociendo-sistema-o-com...

Saludos.

Busque y hay sugerencias acerca de reparar paquetes rotos
con comandos como

sudo apt-get dist-upgrade

añadir el repositorio de vlc

sudo add-apt-repository ppa:lucid-bleed/ppa

añadir claves no publicas

gpg --keyserver subkeys.pgp.net --recv E2BBB94151E77079
gpg --armor --export E2BBB94151E77079 | sudo apt-key add -

es de ubuntugames, no permitia una actualuizacion total, ya lo he solucionado

PSD: los pongo en este orden porque los saque de mi terminal, ya he investigado varios dias y nada, sigue igual pero esto es lo que he hecho como solucion

YAFU escribió:

Hola.
¿Qué es lo que has encontrado al buscar (en el foro, google) sobre ese problema, y sobre el mensaje de error?

Por favor, relee las normas del foro para que comprendas cual es el objetivo del mismo:
http://www.kubuntu-es.org/normas-foro

Si tu pegas capturas de pantalla, luego ese texto de las imágenes (como el del mensaje de error) no será tenido en cuenta en los buscadores, y otros usuarios no podrán encontrar hilos con problemas similares. Por eso siempre transcribe o copia las salidas en forma de texto. Lo mismo para el hardware:
http://www.kubuntu-es.org/wiki/comenzando/howto-conociendo-sistema-o-com...

Saludos.

ok
mi tarjeta de audio

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

dispositivos de reproduccion

tarjeta 0: SB [HDA ATI SB], dispositivo 0: CONEXANT Analog [CONEXANT Analog]
tarjeta 0: SB [HDA ATI SB], dispositivo 1: Conexant Digital [Conexant Digital]
tarjeta 1: HDMI [HDA ATI HDMI], dispositivo 3: ATI HDMI [ATI HDMI]

los que usa el sistema

snd_hda_codec_atihdmi     3023  1
snd_hda_codec_conexant    28873  1
snd_hda_intel          25805  9
snd_hda_codec          85791  3 snd_hda_codec_atihdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep               6924  1 snd_hda_codec
snd_pcm_oss            41394  0
snd_mixer_oss          16299  1 snd_pcm_oss
snd_pcm                87946  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           1782  0
snd_seq_oss            31191  0
snd_seq_midi            5829  0
snd_rawmidi            23420  1 snd_seq_midi
snd_seq_midi_event      7267  2 snd_seq_oss,snd_seq_midi
snd_seq                57481  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23681  3 snd_pcm,snd_seq
snd_seq_device          6888  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    71283  28 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8052  1 snd
snd_page_alloc          8500  2 snd_hda_intel,snd_pcm

En este foro, arriba verás que hay un buscador. Si escribes por ejemplo (sin las comillas): "paquetes rotos" o "instalación incompleta" o "vlc audio" o "vlc audio pulseaudio"

Estoy seguro que encuentras algo mejor que eso que has intentado. Haz esas búsquedas y nos cuentas que es lo que has probado. Si no puedes solucionarlo, pues seguimos aquí.

Ya intentaste con arreglar la actualización a mano desde konsole:

sudo apt-get update
sudo apt-get upgrade

Si esto te tira errores postea y vemos

Muchas veces me he cascado los codecs, procura no salirte demasiado de los repositorios de la distribución, prácticamente todo lo que necesitas lo encuentras en los backports.

despues de hacer una busqueda aqui
me encontre con esta posible solucion

$ sudo dpkg --configure -a
$ sudo aptitude install -f

y la salida fue

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido     
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Los siguientes paquetes están ROTOS:
  glest graphicsmagick-libmagick-dev-compat jackd-firewire kffmpegthumbnailer libavcodec-unstripped-52 mythtv
  mythtv-theme-arclight mythtv-theme-blootube-osd mythtv-theme-blueosd mythtv-theme-graphite
  mythtv-theme-iulius-osd mythtv-theme-metallurgy mythtv-theme-mono-osd mythtv-theme-projectgrayhem-osd
  mythtv-theme-retro-osd mythtv-theme-titivillus-osd mythtv-themes mythtv-transcode-utils python-gtk-vnc
  python-libvirt qemu-kvm simgear2.0.0 stuntrally ubuntu-vm-builder ubuntustudio-graphics vdrift
Se instalarán los siguiente paquetes NUEVOS:
  acl assaultcube assaultcube-data cube-escape debootstrap diffstat fgfs-base gdebi glest-data gpp granatier
  kpartx kvm libauthen-sasl-perl libmythtv-perl libnet-upnp-perl libparse-debcontrol-perl libsdl-mixer1.2
  libterm-size-perl linux-image-2.6.32-36-generic linux-image-2.6.32-38-generic mesa-utils mplayerthumbs ndisgtk
  ndiswrapper-common ndiswrapper-utils-1.9 patchutils perlmagick popularity-contest pwgen python-appindicator
  python-cheetah python-urlgrabber python-vte qemu qemu-common seabios stuntrally-data stuntrally-tracks
  tremulous-data ubuntu-standard update-manager vdrift-data vgabios virtinst watershed wdiff wmctrl
Se RECOMIENDAN los siguientes paquetes, pero NO se instalarán:
  libvirt-bin tremulous
0 paquetes actualizados, 73 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 1302MB/1302MB de archivos. Después de desempaquetar se usarán 1913MB.
No se satisfacen las dependencias de los siguientes paquetes:
  kffmpegthumbnailer: Depende: libffmpegthumbnailer4 pero no es instalable
  mythtv: Depende: mythtv-database pero no es instalable
          Depende: mythtv-frontend pero no es instalable
          Depende: mythtv-backend pero no es instalable
          Depende: ntp pero no es instalable o
                   time-daemon que es un paquete virtual. o
                   ntp-simple que es un paquete virtual.
  vdrift: Depende: libsdl-gfx1.2-4 pero no es instalable
  ubuntu-vm-builder: Depende: python-vm-builder pero no es instalable
  mythtv-themes: Depende: mythtv-theme-mythbuntu pero no es instalable
  mythtv-theme-blootube-osd: Depende: mythtv-common pero no es instalable
  graphicsmagick-libmagick-dev-compat: Entra en conflicto: perlmagick pero se va a instalar 7:6.5.7.8-1ubuntu1.1.
  mythtv-theme-metallurgy: Depende: mythtv-common pero no es instalable
  mythtv-theme-blueosd: Depende: mythtv-common pero no es instalable
  python-gtk-vnc: Depende: libgtk-vnc-1.0-0 (>= 0.3.9) pero no es instalable
  mythtv-theme-iulius-osd: Depende: mythtv-common pero no es instalable
  libavcodec-unstripped-52: Depende: libavcodec-extra-52 (= 4:0.6-2ubuntu3~ppa1~lucid1) pero está instalado 4:0.6.2-1ubuntu2~ppa1~lucid1.
  qemu-kvm: Depende: libaio1 pero no es instalable
            Depende: bridge-utils pero no es instalable
  mythtv-theme-mono-osd: Depende: mythtv-common pero no es instalable
  mythtv-theme-graphite: Depende: mythtv-common pero no es instalable
  mythtv-theme-titivillus-osd: Depende: mythtv-common pero no es instalable
  glest: Depende: libxerces-c28 pero no es instalable
  mythtv-theme-retro-osd: Depende: mythtv-common pero no es instalable
  jackd-firewire: Depende: libffado2 (>= 2.0) pero no es instalable
                  Depende: jackd (= 0.118+svn3796-1ubuntu2) pero no es instalable
  mythtv-theme-arclight: Depende: mythtv-common pero no es instalable
  python-libvirt: Depende: libvirt0 (>= 0.7.5-5ubuntu27.22) pero no es instalable
                  Depende: libxen3 pero no es instalable
  stuntrally: Depende: libboost-filesystem1.40.0 (>= 1.40.0-1) pero no es instalable
              Depende: libboost-system1.40.0 (>= 1.40.0-1) pero no es instalable
              Depende: libmygui3 pero no es instalable
              Depende: libois-1.2.0 pero no es instalable
              Depende: libfreeimage3 pero no es instalable
              Depende: libzzip-0-13 pero no es instalable
              Depende: libogreterrain1.7-1.7.2 pero no es instalable
              Depende: libogrepaging1.7-1.7.2 pero no es instalable
              Depende: libogreproperty1.7-1.7.2 pero no es instalable
              Depende: libogrertshadersystem1.7-1.7.2 pero no es instalable
              Depende: libogremain1.7-1.7.2 pero no es instalable
  mythtv-theme-projectgrayhem-osd: Depende: mythtv-common pero no es instalable
  ubuntustudio-graphics: Depende: blender pero no es instalable
  simgear2.0.0: Depende: libopenscenegraph56 (>= 2.8.1) pero no es instalable
  mythtv-transcode-utils: Depende: mythtv-common pero no es instalable
                          Depende: libmyth-0.23-0 (>= 0.23.0+fixes24158) pero no es instalable
Las acciones siguientes resolverán estas dependencias

Eliminar los paquetes siguientes:
graphicsmagick-libmagick-dev-compat

Instalar los paquetes siguientes:
bridge-utils [1.4-5ubuntu2 (lucid, now)]
libaio1 [0.3.107-3ubuntu2 (lucid, now)]
libmyth-0.23-0 [0.23.0+fixes24158-0ubuntu2 (lucid, now)]
libxerces-c28 [2.8.0+deb1-2build1 (lucid, now)]
mythtv-common [0.23.0+fixes24158-0ubuntu2 (lucid, now)]
tremulous [1.1.0-4.1build1 (lucid, now)]

Mantener los paquetes siguientes en la versión actual:
jackd-firewire [Sin instalar]
kffmpegthumbnailer [Sin instalar]
libavcodec-unstripped-52 [Sin instalar]
mythtv [Sin instalar]
mythtv-themes [Sin instalar]
python-gtk-vnc [Sin instalar]
python-libvirt [Sin instalar]
simgear2.0.0 [Sin instalar]
stuntrally [Sin instalar]
ubuntu-vm-builder [Sin instalar]
ubuntustudio-graphics [Sin instalar]
vdrift [Sin instalar]
virtinst [Sin instalar]

La puntuación es 964

¿Acepta esta solución? [Y/n/q/?] y
Se instalarán los siguiente paquetes NUEVOS:
  acl assaultcube assaultcube-data bridge-utils{a} cube-escape debootstrap diffstat fgfs-base gdebi glest
  glest-data gpp granatier kpartx kvm libaio1{a} libauthen-sasl-perl libmyth-0.23-0{a} libmythtv-perl
  libnet-upnp-perl libparse-debcontrol-perl libsdl-mixer1.2 libterm-size-perl libxerces-c28{a}
  linux-image-2.6.32-36-generic linux-image-2.6.32-38-generic mesa-utils mplayerthumbs mythtv-common{a}
  mythtv-theme-arclight mythtv-theme-blootube-osd mythtv-theme-blueosd mythtv-theme-graphite
  mythtv-theme-iulius-osd mythtv-theme-metallurgy mythtv-theme-mono-osd mythtv-theme-projectgrayhem-osd
  mythtv-theme-retro-osd mythtv-theme-titivillus-osd mythtv-transcode-utils ndisgtk ndiswrapper-common
  ndiswrapper-utils-1.9 patchutils perlmagick popularity-contest pwgen python-appindicator python-cheetah
  python-urlgrabber python-vte qemu qemu-common qemu-kvm seabios stuntrally-data stuntrally-tracks tremulous{a}
  tremulous-data ubuntu-standard update-manager vdrift-data vgabios watershed wdiff wmctrl
Se ELIMINARÁN los siguientes paquetes:
  graphicsmagick-libmagick-dev-compat{a}
0 paquetes actualizados, 66 nuevos instalados, 1 para eliminar y 0 sin actualizar.
Necesito descargar 1322MB/1322MB de archivos. Después de desempaquetar se usarán 1952MB.
¿Quiere continuar? [Y/n/?] y

Despues de un monton de paquetes decidi reiniciar pero al parecer no hizo la gran cosa
el mensaje de los supuetos codecs de video siguen siendo los mismos

E:No se pudieron corregir los problemas, usted ha retenido paquetes
rotos.

y vlc aun no emite audio

Esto tiene pinta a algún repositorio añadido que a estropeado todo (al menos el problema de los paquetes rotos). ¿Tienes idea de cuál repositorio puede haber sido? mas o menos viendo desde cuándo comenzaron los problemas.
¿mythtv, vdrift,...?

el gestor de. paquetes muon no te da la opcion de reparar los paquetes rotos asi como synaptic

YAFU escribió:

Esto tiene pinta a algún repositorio añadido que a estropeado todo (al menos el problema de los paquetes rotos). ¿Tienes idea de cuál repositorio puede haber sido? mas o menos viendo desde cuándo comenzaron los problemas.
¿mythtv, vdrift,...?

los repositorios ya los he tenido desde hace tiempo asi que no creo, digamos hace como 8 meses
solo por curiosidad volvi a introducir los comandos y vi esto

$ sudo aptitude install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido      
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho
Se instalarán los siguiente paquetes NUEVOS:
  libsdl-mixer1.2
0 paquetes actualizados, 1 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B/103kB de archivos. Después de desempaquetar se usarán 279kB.
¿Quiere continuar? [Y/n/?] y
Escribiendo información de estado extendido... Hecho
dpkg: aviso: parsing file '/var/lib/dpkg/available' near line 28850 package 'age-of-conquest-iii':
falta description
(Leyendo la base de datos ... 411064 ficheros o directorios instalados actualmente.)
Desempaquetando libsdl-mixer1.2 (de .../libsdl-mixer1.2_1.2.8-6build1_amd64.deb) ...
dpkg: error al procesar /var/cache/apt/archives/libsdl-mixer1.2_1.2.8-6build1_amd64.deb (--unpack):
intentando sobreescribir `/usr/lib/libSDL_mixer-1.2.so.0', que está también en el paquete sdl-mixer 1.2.11-2
Se encontraron errores al procesar:
/var/cache/apt/archives/libsdl-mixer1.2_1.2.8-6build1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Leyendo lista de paquetes... Hecho                  
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido      
Inicializando el estado de los paquetes... Hecho
sla_x escribió:

los repositorios ya los he tenido desde hace tiempo asi que no creo, digamos hace como 8 meses

Puedes haber tenido los repositorios, pero no haber instalado/actualizado los paquetes que causan conflictos.

Pegar el contenido del archivo /etc/apt/sources.list y el contenido de la carpeta "/etc/apt/sources.list.d". Para no andar copiando manualmente el contenido de esa carpeta, lo puedes ver con:

ls /etc/apt/sources.list.d/
sla_x escribió:

Hace poco mi kubuntu actualizo 53 psquetes

Por cierto, puedes intentar ver en el historial de paquetes instalados/desinstalados/actualizados (/var/log/apt/history.log) cuales fueron los paquetes de aquella vez. Por favor, si vas a pegar esa información, copia solo la parte que creas fueron los paquetes de aquella vez, y no pegues todo el contenido del archivo que esto se hace largo.