Problema conexión cableada router D-LINK en Kubuntu 11.10

Hola Kubunuteros!
Por lo visto tengo el problema inverso a la mayoría de la gente:
Recientemente he instalado un router D-LINK DCM G-202. Antes tenía un cable-modem Thomson que me conectaba a internet por USB. Ahora no consigo que funcione la conexión cableada. Con el WICD la conexión por wifi va muy bien pero no consigo que se conecte por cable ni el WICD ni el NetWork Manager.
Creo que le problema puede ir por el dhclient pero no lo sé seguro. Por si sirve de algo os dejo el resultado de ifconfig:

eth0      Link encap:Ethernet  direcciónHW 00:1e:ec:86:7a:2e 
          Dirección inet6: fe80::21e:ecff:fe86:7a2e/64 Alcance:Enlace
          ACTIVO DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:137 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000
          Bytes RX:0 (0.0 B)  TX bytes:32651 (32.6 KB)
          Interrupción:45 Dirección base: 0xe000

Pues eso es todo.Saludos y gracia de antemano.

hola!
Creo que puede ser un problema de drivers de la tarjeta de red que es:

Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit

Si enchufo un ordenador con Windows 7 se conecta a la primera.

Estoy buscando los drivers para la tarjeta pero no lo encuentro.

¿Sugerencias?

He descargado los drivers para linux de la tarjeta en la web de realtek y he hecho esto

<Linux device driver for Realtek Ethernet controllers>

This is the Linux device driver released for RealTek RTL8168B/8111B, RTL8168C/8111C, RTL8168CP/8111CP, RTL8168D/8111D, RTL8168DP/8111DP, and RTL8168E/8111E Gigabit Ethernet controllers with PCI-Express interface.

<Requirements>

- Kernel source tree (supported Linux kernel 2.6.x and 2.4.x)
- For linux kernel 2.4.x, this driver supports 2.4.20 and latter.
- Compiler/binutils for kernel compilation

<Quick install with proper kernel settings>
Unpack the tarball :
# tar vjxf r8168-8.aaa.bb.tar.bz2

Change to the directory:
# cd r8168-8.aaa.bb

If you are running the target kernel, then you should be able to do :

# ./autorun.sh (as root or with sudo)

You can check whether the driver is loaded by using following commands.

# lsmod | grep r8168
# ifconfig -a

If there is a device name, ethX, shown on the monitor, the linux
driver is loaded. Then, you can use the following command to activate
the ethX.

# ifconfig ethX up

,where X=0,1,2,...

Y aparentemente todo bien, pero nada...

¿Si pruebas estableciendo una IP a mano?

Sí, ya lo he intentado. La ip, la máscara de subred, los DNS, etc...

También he hecho esto:

1 - Downloaded r8168-8.004.00 driver from :
http://wiki.centos.org/HardwareList/RealTekRTL8111b
2 - $ tar jxvf r8168-8.005.00.tar.bz2 # i unpacked this on the desktop
3 - $ sudo mv r8168-8.004.00 /usr/src # move the driver directory from desktop to /usr/src
4 - $ cd /usr/src/r8168-8.004.00
5 - $ sudo make clean modules
6 - $ sudo make install
7 - $ sudo depmod -a
8 - $ sudo insmod ./src/r8168.ko
9 - $ lsmod -a | grep 8186 #just to check it was there
10 - $ cd /etc/modprobe.d
11 - $ sudo touch blacklist-network
12 - $ vi blacklist-network # add r1869 to black list
13 - $ sudo update-initramfs -u #to make the change permanent
14 - reboot
15 - ethtool -i eth0 #to see new driver assigned

Con los datos de mi ordenador claro, no al pie de la letra. y no hay manera.