Los navegadores no reproducen vídeo después de actualizar flash [Solucionado]

Buenas.

Mi problema es que ninguno de los navegadores que tengo (Rekong, Chromium, Firefox) reproducen vídeo desde la última actualización de flash.

Tengo Kubuntu 11.10 actualizado a día de hoy y funcionando sin problema, salvo lo que voy a contar.

Hasta hace poco solía usar la extensión de Firefox "Flash Video Replacer" y me funcionaba sin problema, por lo que hace mucho que no actualizaba el flash en mi navegador principal, que es Firefox 11.0.

Hace poco Kubuntu me pidió actualizar flash (a la "11.2.202.228ubuntu0.11.10.01") y lo acepté, y desde entonces no veo el vídeo en ningún navegador.

En Firefox no aparece ningún mensaje, simplemente un cuadro negro.

En Chromium me aparece el mensaje "Missing Plug-in", igual que en Rekong.

Para Chromium probé a poner en "/etc/chromium-browser/default" este texto:

CHROMIUM_FLAGS=”–enable-plugins”

y nada.

Probé a entrar en modo seguro en Firefox
(Alt + F2 y escribir “firefox -safe-mode”)
desactivando las extensiones y nada, siguen sin verse los vídeos.

Probé con las Preferencias > Aplicaciones de Firefox a poner en todas las opciones de vídeo que me pregunte antes de ejecutarse, y tampoco.

Probé a reiniciar. Nada.

Por supuesto, los archivos de vídeo de mi disco duro sí se reproducen sin problema, esto sólo pasa con el vídeo online.

Si uso ahora "Flash Video Replacer" veo algunos vídeos como los de YouTube en Firefox, pero no los de todos los sitios que conseguía ver antes.

Con Linux Mint 10 en un netbook igual de actualizado no tengo ese problema.

Resumiendo: la última actualización de flash me ha jodido el tema del vídeo online en Kubuntu.

¿Hay alguna manera de arreglarlo desinstalando flash o volviendo a alguna versión anterior? suponiendo que el problema sea del flash, que es lo que supongo.

Por si acaso, pongo una captura de lo último que se me actualizó cuando surgió el problema:

http://www.subirimagenes.com/imagen-putoflash-7585435.html

Tienes los restricted extras? Sino descargate el plugin de la pagina de adobe e instala manualmente. La instalación manual está haca en el foro,que con buscar un poco no hubiese sido necesario abrir un hilo sobre el flash. Y no subas imágenes en donde haya contenido explicito

Gracias por responder.

Quizá debí especificar TODO lo que he hecho antes de poner este post...

Tengo los restricted, por supuesto.

Sí miré en el foro y probé lo que comentan por ejemplo en este post, sin resultado:

http://www.kubuntu-es.org/foro/201203/no-puedo-ver-videos-correctamente-...

Abrí el hilo porque mi problema no es exactamente el mismo (ya que al autor del post se le ha solucionado y a mí no).

También probé a desinstalar flash y reinstalarlo a mano.

Y a desinstalarlo y reinstalarlo desde Apper, Muon y Synaptic.

Por si acaso, probé con la extensión de Firefox "Flash Aid", que mencionan en este post y tiene muy buena pinta. Un apunte: instala la última versión ("11.2.202.228ubuntu0.11.10.1"), o sea, la que me da problemas, así que de poco me sirve:

http://www.kubuntu-es.org/foro/201006/addon-flash-aid-firefox-resuelve-c...

Incluso revisé este post (aunque mi sistema es de 32-bit):

http://www.kubuntu-es.org/wiki/internet-redes/instalar-flash-player-manu...

Otra cosa que hice ya (en mode paranoia ON) fue desinstalar el SMPlayer porque vi que me instaló algo llamado "smtube" (SMPlayer Youtube Browser), y lo quité por si acaso.

Pero nada de todo esto me ha funcionado. Por eso puse el post.

Mi problema NO es que no tenga flash ni que no pueda o no sepa instalarlo, sino que la última actualización me ha jodido el tema del vídeo.

Después de hacer todo esto mi idea es que la culpa es de la última actualización de flash, porque hasta entonces no tuve problemas. También como dije antes hace mucho que no lo actualizaba porque usaba "Flash Video Replacer" en Firefox sin problema y no echaba de menos flash.

Por eso preguntaba si a alguien con esa versión de flash le pasa lo que a mí, y si alguien sabe qué otra cosa puedo hacer.

P.S. No entiendo lo de "no subas imágenes en donde haya contenido explicito". Es una captura de mi pc...

j escribió:

P.S. No entiendo lo de "no subas imágenes en donde haya contenido explicito". Es una captura de mi pc...

La captura sí, pero fíjate en los banners de la página donde está alojada esa captura, son de los guarrillos.

¿Qué versión de kernel usas? A veces he visto el caso en que la actualización de flash se lleva mal con alguna versión del kernel y he tenido que usar otra para que funcionase.

Ah, vaya lol . Como uso Firefox con NoScript no me abría ese banner, ni sabía que existían en esa web, vaya. Pero con descargar la imagen en vez de hacer clic en ella (o usar esa extensión) problema resuelto.

Por cierto, no puse la imagen en el servidor del foro porque al reescalarla no se veía bien el texto.

Mi kernel es 3.0.0-12.

No me digas que tengo que cambiar de kernel (¿encima downgrade?) sólo para poder ver vídeos, porque entonces paso. Seguiría usando "Flash Video Replacer" y que le den a Adobe mucho por el flash.

Pero espero que haya alguna solución menos radical...

Y gracias por responder.

¿De verdad que a nadie más le pasa? De repente no es el flash, miren bien la captura por si acaso.

EDITO: como lo había desinstalado del todo, me ha vuelto pedir instalar flash. Lo he he hecho y... Nada, sigo igual. Y probé con el viejo Konqueror, ídem.

En la captura veo que has desinstalado el último kernel, el 3.0.0.17.20 ¿Lo has vuelto a instalar?
¿Tienes disponible el paquete "flasplugin-nonfree"? Si lo tienes prueba con ese.

sudo apt-get install flashplugin-nonfree
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
El paquete flashplugin-nonfree es un paquete virtual provisto por:
  adobe-flashplugin 11.2.202.228-0maverick1
  flashplugin-installer 11.2.202.228ubuntu0.11.10.1
Necesita seleccionar explícitamente uno para instalar.
E: El paquete «flashplugin-nonfree» no tiene un candidato para la instalación

El paquete flashplugin-nonfree es un paquete virtual provisto por ¿¿Adobe??

¿Y el kernel?

Esta raro, porque yo estoy usando la beta de kubuntu y no anda nada mal. No has intentado agregar el ppa del flash?

Pues a mí me pasa exactamente igual. Y he intentado más o menos lo mismo. Incluso la instalación manual...

Después de actualizar flash (a la "11.2.202.228ubuntu0.11.10.01") no veo vídeos que necesiten el plugin de flash. Antes iba muy bien.
Llevo días googleando y durmiendo poco para nada. Lo único que puedo hacer es pasar del adobe flashplugin y usar gnash.

Pero lo curioso del caso es que en casa tengo 4 ordenadores con Kubuntu. Todos con Kubuntu 10.04 y actualizados al último kernel por igual y con la misma versión de Firefox (todos se actualizan por igual). Instalados:
ii linux-image-2.6.32-37-generic 2.6.32-37.81
ii linux-image-2.6.32-38-generic 2.6.32-38.83
ii linux-image-2.6.32-39-generic 2.6.32-39.86
ii linux-image-2.6.32-40-generic 2.6.32-40.87

El problema se da en ese ordenador con cualquiera de los kernels que use.

En uno de ellos, uno de torre (desktop?) es donde está el problema, para todos las cuentas de usuarios.
En los otros 3 (dos de sobremesa, DELL Optiplex) y un portátil (laptop Acer Extensa) no existe ese problema.

los síntomas que tengo son: Si hay una página que contenga un vídeo embebido en flash (por ejemplo ésta página de un foro, trankis es legal :-)) no se ve ni el cuadrado.
En Youtube se queda en negro unos segundos o minutos, y luego arranca el vídeo pero no se ve mediante el flash plugin, sino por ser HTML5, por lo que veo dando al botón derecho.

Dentro de las muchas cosas más que pudieran haber de diferentes entre los ordenadores citados, una notoria es la tarjeta gráfica. En el que falla es una ATI RADEON. El portátil es Nvidia y los otros dos son integradas en placa base.

En Google Chrome me pasa lo mismo que a jositogordillo, dice "plugin missing", aunque si hago about:plugins allí está el
Flash - Versión: 11.2 r202
Shockwave Flash 11.2 r202

He intentado pone algún paquete de versiones anteriores, pero como funciona "on-line" siempre acaba con la versión última y me quedo igual.

Mientras tanto, tendré que usar gnash, aunque no todos los vídeos se ven bien... Y en concreto youtube se ve mejor tal cual, sin plugines que con gnash

Se aceptan ideas.

Parece mentira... eek

Después de todo el rollo, vuelvo a googlear y encuentro una web que habla de algo parecido (en ubuntu algunos lo ven en azul y mal) y aporta algunas soluciones. No del todo perfectas, pues no localizan-resuelven el problema causa, pero bueno:

http://n3ri.com.ar/2012/03/solucion-al-problema-de-flash-player-en-ubuntu-los-videos-se-ven-de-color-azul/

He utilizado la solución 2: he copiado (y sobrescrito) el libflashplayer.so de la versión 10.3.183.18 (que también corregiría vulnerabilidades) en /usr/lib/flashplugin-installer/ y funciona bien Firefox 11.0 y Chromium. Falla Konqueror, pero lo uso poquísimo, así que no me molesto en más.

(Lo he bajado de la web de Adobe, es un zip de 67 Mb, pero basta con localizar el archivo ese y copiarlo. Dentro del zip está en el comprimido /fp_10.3.183.18_archive/10_3r183_18/flashplayer10_3r183_18_linux.tar.gz).

Problema será de que no se sabe cómo actualizará en un futuro, pues ahora cree que se trata del 11.2.202...

aptitude show -V flashplugin-installer
...
Versión: 11.2.202.228ubuntu0.10.04.1

(Por cierto, por curiosidad, he bajado también el paquete 11.2.202.228 para usar el libflashplayer.so, por si era otro archivo distinto o que funcione, y da el mismo problema)

Como el hilo es de jositogordillo, si lo da por solucionado, que lo marque please... contrato