No funcionan mis 2 monitores con tarjeta de video AMD Radeon HD6850

Hola a todos. Aclaro q uso 2 monitores y lo q busco es ponerlos como escritorio extendido.
Al iniciar Kubuntu un monitor se veia bien, pero el otro mostraba rayas negras y blanca y parpadeaba. Lo que se me ocurrio fue instalar el controlador de AMD. Cuando lo fui a instalar (baje el archivo .run desde la web de amd) lo puse como ejecutable y lo ejecute. me pedia la contraseña del admin, le pongo la contraseña del admin, pero luego se cierra y me dice que necesito ser un super-usuario, y lo soy. probe con sudo sh, pero tampoco va. Al final lo instale desde "controladores adicionales". Cuando reinicio se pusieron los dos en espejo. Fui a Pantalla y Monitor y lo cambie (puse derecha de) y cuando pongo aplicar la configuracion vuelve a como estaba. Entonces probe ir al catalyst control center, encuentro 2 iconos, el administrativo y el comun. Abro el 2do y voy a administracion de pantalla, pero me dice q para efectuar cambios necesito ejecutarlo con permisos administrativos. Entonces le hago caso, cierro y abro el administrativo, y me pide clave de usuario, se la pongo y se cierra.

Haz probado reinstalar?
o aun mejor usar los controladores libres desde la pagina de amd

Hola.
Lee y cumple las normas del foro que has aceptado al registrarte:
http://www.kubuntu-es.org/normas-foro

Es importante que des información de tu hardware (solo el que es relativo al problema en cuestión) como se indica aquí:
http://www.kubuntu-es.org/wiki/comenzando/howto-conociendo-sistema-o-com...

melee647 escribió:

o aun mejor usar los controladores libres desde la pagina de amd

Querrás decir, ¿"privativos" desde la página de AMD?
Si es así, los privativos son los "Catalyst" de los que habla el usuario.

Saludos.

PD: Ya que hablas de abrir aplicaciones gráficas con permisos, quizás debas saber lo siguiente (si es que no lo sabes):
http://www.kubuntu-es.org/wiki/sistema/por-que-se-debe-usar-kdesu-o-kdes...

Perdon por lo del hardware, la normas las lei en el momento en que me registre, pero me olvide de escribir el HW. Mi Placa de video es una AMD Radeon HD6850.

melee647 escribió:

Haz probado reinstalar?
o aun mejor usar los controladores libres desde la pagina de amd

Como contraoladores libres de la pag de amd?? segun tengo entendido son privativos al ser de amd, como dijo YAFU. Y esos son los q tuve problemas con la instalacion, entonces fui a controladores adicionales y de ahi baje los privativos.

Con el comando kdesudo me dice Cant open ./ y el archivo q ahora no recuerdo como se llama.

Una cosa mas, q diferencia hay entre el controlador libre y el privativo??

jaks escribió:

Perdon por lo del hardware, la normas las lei en el momento en que me registre, pero me olvide de escribir el HW. Mi Placa de video es una AMD Radeon HD6850.

melee647 escribió:

Haz probado reinstalar?
o aun mejor usar los controladores libres desde la pagina de amd

Como contraoladores libres de la pag de amd?? segun tengo entendido son privativos al ser de amd, como dijo YAFU. Y esos son los q tuve problemas con la instalacion, entonces fui a controladores adicionales y de ahi baje los privativos.

Con el comando kdesudo me dice Cant open ./ y el archivo q ahora no recuerdo como se llama.

Una cosa mas, q diferencia hay entre el controlador libre y el privativo??

La diferencia, es que el privado solo puede ser distribuido y modificado por el fabricante, el libre... ya se sabe
da click aqui aun cuando tengas activado el controlador privado de kubuntu, bajar e instalar de esta pagina suele ser mas util
Saludos.

jaks escribió:

Perdon por lo del hardware, la normas las lei en el momento en que me registre

Fíjate los puntos 04 y 05 de las normas. El 04 tenlo en cuenta para la próxima porque tu ya no puedes editar el título. Se pide en el título una breve descripción de ese "problema" que dices tener. Y la 05, si bien no escribes con lenguaje SMS, el "q" en lugar de "que" puede considerarse como tal. Intenta evitar esa mala costumbre.

El driver "libre" es "código abierto" y es un desarrollo comunitario. El "privativo" tiene licencia justamente privativa, es "código cerrado" y es un desarrollo de AMD/ATI. Puedes leer sobre código abierto(software libre y Open Source) y software de código cerrado buscando en internet.

El driver con que inicias luego de la instalación de Kubuntu es el driver libre (instalado por defecto). Si lo instalas desde controladores adicionales estarás instalando el driver privativo posiblemente en una versión anterior a la que puedes encontrar descargando desde el sitio de ATI.

El siguiente sitio en ingles es el wiki de referencia para instalación y configuración de los drivers Catalyst de ATI:
http://wiki.cchtml.com/index.php/Ubuntu

Allí (para Oneiric) hay una nota sobre "Dual/Multi Monitors".

melee647 escribió:
jaks escribió:

Perdon por lo del hardware, la normas las lei en el momento en que me registre, pero me olvide de escribir el HW. Mi Placa de video es una AMD Radeon HD6850.

melee647 escribió:

Haz probado reinstalar?
o aun mejor usar los controladores libres desde la pagina de amd

Como contraoladores libres de la pag de amd?? segun tengo entendido son privativos al ser de amd, como dijo YAFU. Y esos son los q tuve problemas con la instalacion, entonces fui a controladores adicionales y de ahi baje los privativos.

Con el comando kdesudo me dice Cant open ./ y el archivo q ahora no recuerdo como se llama.

Una cosa mas, q diferencia hay entre el controlador libre y el privativo??

La diferencia, es que el privado solo puede ser distribuido y modificado por el fabricante, el libre... ya se sabe
da click aqui aun cuando tengas activado el controlador privado de kubuntu, bajar e instalar de esta pagina suele ser mas util
Saludos.

Desde esa pagina los bajo, siempre los baje de ahí, pero al no poder instalarlos los baje desde controladores adicionales.

YAFU escribió:
jaks escribió:

Perdon por lo del hardware, la normas las lei en el momento en que me registre

Fíjate los puntos 04 y 05 de las normas. El 04 tenlo en cuenta para la próxima porque tu ya no puedes editar el título. Se pide en el título una breve descripción de ese "problema" que dices tener. Y la 05, si bien no escribes con lenguaje SMS, el "q" en lugar de "que" puede considerarse como tal. Intenta evitar esa mala costumbre.

El driver "libre" es "código abierto" y es un desarrollo comunitario. El "privativo" tiene licencia justamente privativa, es "código cerrado" y es un desarrollo de AMD/ATI. Puedes leer sobre código abierto(software libre y Open Source) y software de código cerrado buscando en internet.

El driver con que inicias luego de la instalación de Kubuntu es el driver libre (instalado por defecto). Si lo instalas desde controladores adicionales estarás instalando el driver privativo posiblemente en una versión anterior a la que puedes encontrar descargando desde el sitio de ATI.

El siguiente sitio en ingles es el wiki de referencia para instalación y configuración de los drivers Catalyst de ATI:
http://wiki.cchtml.com/index.php/Ubuntu

Allí (para Oneiric) hay una nota sobre "Dual/Multi Monitors".

Lo de la "q" voy a intentar eliminar esa costumbre.
Sobre el driver, creo que me exprese mal, ya se que el privativo lo hace AMD y el libre es código abierto. A lo que me refería es a si hay alguna diferencia notoria entre uno y el otro. Ya que si es lo mismo, me quedo con el libre y listo.

En ese wiki al principio dice que hay problemas con la serie 6xxx pero que se solucionan. Después fui a Oneiric y ejecute los comando que dice ahí, pero sigue igual, También dice que quizás tenga que ajustar la frecuencia manualmente desde el catalyst, pero al abrir el catalyst no se me abre.

Meto mi cuchara. Eso de si hay diferencias o no puede variar,ya que he leido por experiencias de otros...que a algunos si les resulta el privativo a otros no,consecuencias:Posible aumento de temperatura y mayor consumo de recursos. Para checar la temperatura hay varias formas:con la terminal con

sudo apt-get install lm-sensors

Luego ejecutas sensors y te saldrá la temperatura,también con jupiter,este es un programa para gestionar algunos recursos. Buscando en google puedes saber si te conviene o no,osea,busca tu modelo etc...experimenta obviamente.Saludos

¿Diferencia en rendimiento?
Como dice gaska92, hay modelos de tarjetas que funcionan mejor con uno, y otras con el otro. Tu sabrás probar y comprobarlo con tu tarjeta.
Si utilizas el driver libre, si es que no puedes ponerlo como escritorio extendido desde las preferencias del sistema, busca en internet sobre "xrandr". Tendrás que usar la terminal pero podrás experimentar sin temor a estropear algo, ya que los cambios con xrandr son en tiempo real pero no quedan guardados (salvo que hagas un script de inicio) y al reiniciar vuelve todo como lo tenías. Entonces si logras ponerlo como extendido, solo tendrás que hacer un script con las instrucciones que has usado y ejecutarlo cuando quieras. Por supuesto que para que funcione, ambas pantallas deben ser detectadas correctamente con sus resoluciones y frecuencias permitidas.

gaska92 escribió:

Meto mi cuchara. Eso de si hay diferencias o no puede variar,ya que he leido por experiencias de otros...que a algunos si les resulta el privativo a otros no,consecuencias:Posible aumento de temperatura y mayor consumo de recursos. Para checar la temperatura hay varias formas:con la terminal con

sudo apt-get install lm-sensors

Luego ejecutas sensors y te saldrá la temperatura,también con jupiter,este es un programa para gestionar algunos recursos. Buscando en google puedes saber si te conviene o no,osea,busca tu modelo etc...experimenta obviamente.Saludos

Intente instalar sensors y no pude. Esto es lo que me dice:

javier@javier-kubuntu:~$ sudo apt-get install lm-sensors
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
plasma-widgets-addons : Depende de: plasma-dataengines-addons (= 4:4.7.4-0ubuntu0.1) pero 4:4.7.1-0ubuntu2 va a ser instalado
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).
javier@javier-kubuntu:~$ apt-get -f install
E: No se pudo abrir el archivo de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»

Ahi dice algo sobre plasma-widgets-addons (no se lo que es), y cuando lo ejecute por primera vez me salio lo siguiente:

javier@javier-kubuntu:~$ sudo apt-get install lm-sensors
E: se interrumpió la ejecución de dpkg, debe ejecutar manualmente «sudo dpkg --configure -a» para corregir el problema
javier@javier-kubuntu:~$ sudo dpkg --configure -a

Y luego empezo a configurar, al final aparecio esto:

Se encontraron errores al procesar:
plasma-widgets-addons

Igual no creo que la temperatura de la vga este alta, ya que la BIOS maneja su fan para tener la temperatura rondando los 60 grados, que es muy normal en mi VGA. Además no es lo que pregunto, así que supongo que estoy desvirtuando el tema, es solo para aclarar.

YAFU escribió:

¿Diferencia en rendimiento?
Como dice gaska92, hay modelos de tarjetas que funcionan mejor con uno, y otras con el otro. Tu sabrás probar y comprobarlo con tu tarjeta.
Si utilizas el driver libre, si es que no puedes ponerlo como escritorio extendido desde las preferencias del sistema, busca en internet sobre "xrandr". Tendrás que usar la terminal pero podrás experimentar sin temor a estropear algo, ya que los cambios con xrandr son en tiempo real pero no quedan guardados (salvo que hagas un script de inicio) y al reiniciar vuelve todo como lo tenías. Entonces si logras ponerlo como extendido, solo tendrás que hacer un script con las instrucciones que has usado y ejecutarlo cuando quieras. Por supuesto que para que funcione, ambas pantallas deben ser detectadas correctamente con sus resoluciones y frecuencias permitidas.

OK voy a ver si me conviene el driver libre, lo que pasa es que con el driver libre el monitor derecho me mostraba lineas negras y blancas, solo cuando lo ponía en extendido. Tengo una suposición, pero no se si es acertada, al configurarlo (con el driver libre) me decía que el izquierdo estaba en HDMI-0 (cosa que es correcta), pero el otro me decía DVI-0; ese monitor tiene entrada VGA, pero mi placa de video no tiene salida VGA, pero viene con un adaptador pasivo DVI-VGA. Estos adaptadores, según tengo entendido, puentean 2 cables para indicarla a la tarjeta que esta conectado, y la tarjeta manda la imagen de forma analógica. Quizás este funcionando mal por el tema del driver y lo mada de forma digital, y el monitor muestra eso. Igual creo que esto no es acertado, ya que el tema del adaptador lo maneja la BIOS de la tarjeta, no el driver.

Intentaste primero con el apt-get -f install?
luego debiste hacer lo de sudo dpkg --configure -a

Intenta instalando otra cosa a ver que te dice.Obvio desde la terminal y bueno te dejo el ppa de jupiter:

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter

Abres la app y luego reinicias,te saldrá a en el panel un rayo,das click derecho y te aparecerá la temperatura y otras configuraciones.