HOW TO: Instalar el decorador de ventanas "Oxígen-transparent" (Ventanas transparentes) [Solucionado]

Ralsa escribió:

Voy a dar una opinión discordante, a mí me parece visualmente cargante. No me duraría ni dos minutos.

si lo configuras como en la captura sí da asco y encima no ves las letras. Pero las transparencias las puedes configurar a tu gusto tanto para la ventana como para su decoración independientemente. Si la opacidad la pones del 85% al 95% queda espectacular.

Saludos.

Por cierto, se puede desactivar perfecta y fácilmente así que SÍ hay vuelta atrás.

CHuLoYo escribió:

si lo configuras como en la captura sí da asco y encima no ves las letras. Pero las transparencias las puedes configurar a tu gusto tanto para la ventana como para su decoración independientemente. Si la opacidad la pones del 85% al 95% queda espectacular.
Saludos.

:P se supone que la transparencia que se le de va a ser la adecuada para cada gusto, la captura que subí muestra casi el máximo de transparencia, entiendase que es para mostrar el efecto.

En mi caso, con un 40% de transparencia me queda muy bien :D

osso_maxi escribió:
CHuLoYo escribió:

si lo configuras como en la captura sí da asco y encima no ves las letras. Pero las transparencias las puedes configurar a tu gusto tanto para la ventana como para su decoración independientemente. Si la opacidad la pones del 85% al 95% queda espectacular.
Saludos.

:P se supone que la transparencia que se le de va a ser la adecuada para cada gusto, la captura que subí muestra casi el máximo de transparencia, entiendase que es para mostrar el efecto.

En mi caso, con un 40% de transparencia me queda muy bien :D

Por supuesto, era obvio que era para mostrar el efecto, pero también es obvio que al máximo de transparencia no se puede trabajar.

saludos :)

Hay un script con el cual yo lo instalé.

Antes que nada instalamos los paquete necesarios para la compilación (build-essential, cmake, git, kdelibs5-dev, kdebase-workspace-dev, libxrender-dev y libx11-dev):

$ sudo apt-get install build-essential cmake git kdelibs5-dev kdebase-workspace-dev libxrender-dev libx11-dev

Creamos el directorio y entramos en él:

$ mkdir oxygen-transparent && cd oxygen-transparent

Lo descargamos con el comando wget:

$ wget http://kde-look.org/CONTENT/content-files/127752-oxygen-setup.pl

Le damos los permisos de ejecución al script:

$ chmod +x 127752-oxygen-setup.pl

Ejecutamos el script:

./127752-oxygen-setup.pl

Entramos al directorio «build» que nos generará al ejecutar el script e instalamos la compilación:

$ cd build && sudo make install

Por último reiniciamos sesión.

first Gracias

a mi no me ha funcionado, le he dado toda la trasparencia, pero no me la cambia, estoy usando Kubuntu de 64 bits.
cuando coloco la linea: cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
me sale esto

elf025@ThinkPad:~/oxygen-transparent$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.

-- Found Qt-Version 4.7.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libXau.so;/usr/lib/x86_64-linux-gnu/libXdmcp.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libXau.so;/usr/lib/x86_64-linux-gnu/libXdmcp.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Found Phonon: /usr/include
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.6 include dir: /usr/include
-- Found KDE 4.6 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Configuring done
-- Generating done
-- Build files have been written to: /home/elf025/oxygen-transparent
elf025@ThinkPad:~/oxygen-transparent$

no se si tenga algo que ver eso de "not found"
saludos

y terminaste con todos los pasos?

gracias por el aporte, funsiona al 100.

uplink escribió:

gracias por el aporte, funsiona al 100.

confirmo: yo segui el procedimiento en la 10.04 y funcionaba perfectamente, ahora en la 11.04 tambien va de maravilla, se lo puede apreciar en el video que acabo de subir sobre Como unir videos facilmente con Avidemux :)

Saluti e abbraci