Picasa no abre los archivos de imagenes. Nunca se inicia el programa [Solucionado]

Buenas a todos. Hace poco instalé el Picasa versión 2.7 en mi Kubuntu 10.10. Para efectuar la instalación, me descargué el archivo .deb de esta dirección: http://picasa.google.com/linux/thanks-deb.html.
A continuación procedí con los pasos habituales listados en la misma página para finalizar el proceso de instalación. A saber:
$ su
# dpkg -i /tmp/picasa_2.7.3736-15_i386.deb
# exit
Todo funcionó sin mayores inconvenientes. El icono del programa se muestra en el menú de Gráficos del sistema, sin embargo, al momento de intentar iniciar el programa, siempre se muestra el icono del mismo por espacio de unos cuantos segundos, en señal de que el software se esta cargando, el problema es que este nunca se termina de cargar. El icono desaparece al cabo de unos segundos pero el programa nunca se muestra.
¿Existe alguna manera o comando que me permita saber cual es el problema que esta impidiendo el inicio del Picasa?
Saludos.

Ejecutalo desde una consola para ver cual pueda ser el problema.

gracias por responder. Esto es lo que me muestra la consola:
lucas@lucas-Satellite-L305:~$ picasa
/usr/bin/picasa: line 139: 5921 Segmentation fault "$PIC_BINDIR"/wrapper check_dir.exe.so
/usr/bin/picasa: line 175: 6024 Segmentation fault "$PIC_BINDIR/wrapper" regedit /E $registry_export HKEY_USERS\\S-1-5-4\\Software\\Google\\Picasa\\Picasa2\\Preferences\\

No se si a eso te referias.

Nunca he usado Picasa asi que no se de que sea.
Buscando encontre 2 cosas, en una decian que era un problema de WINE y el otro que es un fallo en la versión 2.7.

http://www.fedoraforum.org/forum/showthread.php?t=222601

Segun este hilo(de Fedora) tienen el mismo error en el que dicen que si instalan la versión 3 beta si funciona.

Gracias por la sugerencia. Aparentemente la version del programa que estaba usando no funciona bien en varios sistemas GNU/Linux, pero el Picasa 3 anda sin problemas.
Saludos.