Sin entorno grafico en kubuntu 10.04

Buenas tardes a todos biggrin, por enesima me vez se me presenta un problema como este cheesygrin pero lo malo de este es que no lo he podido solucionar, ya he buscado en foros, en google, aqui, y otras comunidades gnu/linux y nada cry , esto es lo que paso.

Todo estaba completamente bien despues de la instalacion normal de kubuntu 10.04 (i386), despues de la instalacion de algunos programas basicos, decidi instalar los drivers oficiales de nvidia, 256.35. Despues de la descarga e intentos de intalarlo lo logre ( me faltaban unos programas o paquetes como los linux-headers biggrin ). entonces reinicio y no inicia el modo grafico evil , bueno se como solucionarlo, ejecuto "cp xorg.conf.backup xorg.conf" y listo. Despues de eso lo vuelvo a intentar y me dio el mismo problema, asi que descarge una version del driver mas antigua (173.14.25), descargue esta version porque ya la habia instalado con anterioridad y sabia que funcionanba perfectamente con mi hardware.

Ahora el verdadero problema:

supuse que debia desinstalar el driver 256.35, asi que ejecuto "sudo ./NVIDIA.run --uninstall" (le cambie el nombre al archivo para manejarlo con mas facilidad). posteriormente sale el mensaje que se a desinstalado correctamente, pero a apartir de aqui mas nunca volvio a iniciar el entorno grafico exclaim . Despues de verificar el estado del xorg.conf y notar que seguia igual, procedi a instalar el 173.14.25, con el mismo resultado.

Bueno basicamente eso es lo que hice y algo mas cuando enciendo mi pc y se carga el kdm y me pide la contraseña (cosa que me parece rara porque en la instalacion seleccione iniciar sin requerir contraseña), la escribo y me sale un cuadrito gris en la esquina izquierda superior de mi monitor y me vuelve a salir la pantalla de kdm, si me vuelvo a loguear esta vez, me manda para una de las terminales ( usualmente tty2).

A continuacion los xorg.conf :

original (este es el que se creo al instalar el SO)


Section "Device"
         Identifier  "Configured Video Device"
         Driver      " fbder"
EndSection
Section "Monitor"
         Identifier  "Configured Monitor"
EndSection
Section "Screen"
         Identifier  "Default Screen"
         Monitor     "Configured Monitor"
         Device      "Configured Video Device"

xorg.conf creados por alguno de los drivers de nvidia

#nvidia-xconfig : xconfiguration file generated by nvidia-xconfig
#nvidia-xconfig : version 256.35 (buildmeister@builder100) wed Jun 16 19:25:59 PDT 2010

Section "Server Layout"
         Identifier   "Layout0"
         Screen    0  "Screen0"
         InputDevice  "Keyboard0" "CoreKeyboard"
         InputDevice  "Mouse0" "CorePointer"
EndSection
Section "Files"
EndSection
Section "InputDevice"
# generated from Default
         Identifier   "Mouse0"
         Driver       "Mouse"
         Option       "Protocol" "Auto"
         Option       "Device" "/dev/psaux"
         Option       "Emulate3 Buttons" "no"
         Option       "ZaxisMapping" "4 5"
EndSection
Section "ImputDevice"
# generated from Default
         Identifier   "Keyboard0"
         Driver       "kbd"
EndSection
Section "Monitor"
         Identifier   "Monitor0"
         VendorName   "Unknow"
         ModelName    "Unknow"
         HorizSync    28.0 - 33.0           
         VertRefresh  43.0 - 72.0
         Option       "DPMS"
EndSection
Section "Device"
         Identifier   "Device0"
         Driver       "nvidia"
         VendorName   "NVIDIA CORPORATION"
EndSection
Section "Screen"
        Identifier    "Screen0"
        Device        "Device0"
        Monitor       "Monitor0"
        DefaultDepth  24
           Subsection   "Display
               Depth    24
        EndSubsection
EndSection

Mi tarjeta de video es una XFX 9800GTX+ cheesygrin, bueno eso es todo, si necesitan mas informacion con gusto se las dare, y gracias de antemano cheesygrin smile

Me da a mi que realmente no tienes desinstalada la versión 256.35, prueba con

dpkg --get-selections | grep nvidia

a ver que tienes instalado de nvidia

esto es lo que me mostro :

dpkg  --get-selections | grep nvidia

nvidia-173-modaliases
nvidia-96-modaliases
nvidia-common
nvidia-current-modaliases

y un dato mas neutral para instalar cualquiera de los drivers utilice este comando "sudo ./NVIDIA.run -k $(uname -r)", porque tenia un problema con los kernels question (cosa que tampoco entendi muy bien)

Instala el ultimo Driver de NVIDIA y cuando ya lo tengas instalado ejecuta

sudo update-initramfs -u

Y prueba

Zarge escribió:

esto es lo que me mostro :

dpkg  --get-selections | grep nvidia

nvidia-173-modaliases
nvidia-96-modaliases
nvidia-common
nvidia-current-modaliases

Ahí faltan paquetes, de todas formas yo probaría lo que dice tuxerito.

Zarge escribió:

y un dato mas neutral para instalar cualquiera de los drivers utilice este comando "sudo ./NVIDIA.run -k $(uname -r)", porque tenia un problema con los kernels question (cosa que tampoco entendi muy bien)

Si te vuelve a salir añádelo y vemos si está implicado o merece un hilo propio.

Hola otra vez cheesygrin, estos son los mensajes que me aparecen cuando instalo ( o intento exclaim ) los drivers :

"sudo ./NVIDIA.run"

There appears to already be a installed on your system (versin 256.35). As part of installing this drivers (version 256.35) the existing drivers will be unistalled. Are sure you want to continue ('no' will abort installation)
The distribution-provided pre-install script failed!
continue installation anyway?

Despues sale una barra de progreso con el titulo de "Building kernel module"

Error: Unable to load the kernel module 'nvidia.ko'.
This happens most frequently when this kernel module was built against wrong or improprely configured kernel sources, with a version of gcc tha differs from the one used to build the target kernel, or if a driver such as rivafb/nvidiafb is present and prevents the NVIDIA kernel module from obtaining ownership of NVIDIA graphics device(s) on NVIDIA GPU installed in this system is not supported by this NVIDIA Linux graphics drivers release.
Please see the log entries 'kernel module load error' and 'kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information
Error: installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README avaliable on the Linux driver download page at www.nvidia.com

si ejecuto "sudo ./NVIDIA.run -k $(uname -r)" solo me salen los 2 primeros mensajes, luego varias barras de progreso y los siguientes mensajes

Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so tha the NVIDIA X driver will be used went you restart X? Any pre-existing X configuration file will be backed up.
Your X configuration file has been succesfully update. Installation of NVIDIA Accelerated Graphics Driver from Linux-x86 (version 256.35) is now complete

Despues de eso ejecute "sudo update-initramfs -u"

update-initramfs: Generating /boot/initrd.ing-2.6.32-24-generic

Eso es todo por ahora cheesygrin

El primer mensaje dice que ya lo tienes instalado, o al menos parte. tienes que hacer desaparecer todos los paquetes de nvidia antes de empezar la instalación.

¿Reinicaste el sistema luego de ejecutar sudo update-initramfs -u?

hola, si reinicie despues de ejecutar sudo update-initramfs -u y no paso nada sad , simplemente me sigue enviando a tty2. Entonces vuelvo a ejecutar dpkg --get-selections | grep nvidia para ver que paquetes tengo de nvidia e intento nuevamente instalar el driver ?

Antes de instalar el driver elimina todos los paquetes de aparezcan con el dpkg.

Saludos otra vez, ahorita acabo de eliminar cualquier paquete que tuviera la palabra NVIDIA biggrin , y volvi a instalar el driver a ver que pasaba; pero lastimosamente no ocurrio nada todo sigue igual cry .

no se si servira de algo pero la parte que deberia ser grafica (ctrl + alt + F7), se puede leer las siguientes lineas

*Starting Network connection manager wicd    [ok]
*Staring Common Unix Printing System: cupsd  [ok]
*Checking battery state...                   [ok]