instalo 10.04 pero el modo grafico no arranca

instalo kubuntu 10.04 en alternate ya que si no el modo grafico no funciona, despues si arranco normal la pantalla se me hace negra con 3 bandas de colores en la parte de arriba, asi que arranco para recuperar el sistema y de ahí arranco con la consola como root. Sabiendo que es la grafica, me dispongo a instalar los restricted extras, me dice que el paquete no se encuentra. Si intento editar con kate /etc/apt/sources.list me dice que:
Kate: cannot connect to X server
si lo hago por Kde sudo me dice lo mismo
Kdesudo: cannot connect to X server
Tambien he intentado instalar la grafica por envyng, pero me dice que no se puede encontrar el paque te envyng.
No se que mas hacer, pero se que el problema es la grafica porque mandriva arrancaba sin ningun problema el entorno grafico. Pero no quiero instalar mandriva porque me gusta mas kubuntu. A ver si me podeis ayudar, por favor.

¿Y qué gráfica es?

el tema además es que el editor para la consola es nano (bueno, uno de ellos) kate solo sirve si te funciona el entorno gráfico. Pero deberías empezar aportando algo más de información.

la grafica es la nvidia g102m, es un portatil asus. Que informacion necesitais? Gracias.

para empezar, intenta editar el xorg.conf con nano (seguramente ni exista ese archivo), a ver si puedes arrancar con el driver vesa o el nouveau.

Puedes intentar generar un xorg.conf adecuado a tu sistema con

sudo X -configure

puedo editar con nano, pero despues de editar, sigo sin poder instalar los restricted extras.
He creado el xorg.conf.new con el comando que me has dado.
En el aparatado de la grafica, aparece:
Section "Device"
### Avaible Driver options are:-
### Values i: integer, f: float, Bool: True/False
### string : "string" freq f
### arg: arg optional
#Option "ShadowFB"
#Option "rotate"
#Option "fbdev"
#Option "debug"
Identifier "Card0"
Driver "fbdev"
Vendorname "nVidia Corporation"
BoardName "C79 (GeForce G102M)
Bus ID "PCI:2:0:0"

Se me ocurre que en modo de restauracion a lo mejor no tengo internet por wifi, puede ser? como puedo comprobar que tengo conexion para descargarme los repositorios?
Gracias de nuevo

vamos por partes.

primero, el xorg.conf.new que se te ha creado no te sirve si no lo mueves a /etc/X11/xorg.conf (sin el .new)

cp xorg.conf.new /etc/X11/xorg.conf

segundo, la linea del Driver pon vesa de momento (puedes probar con nouveau también, pero vesa seguro que funciona, y casi seguro que nouveau también)

Citar

Section "Device"
### Avaible Driver options are:-
### Values i: integer, f: float, Bool: True/False
### string : "string" freq f
### arg: arg optional
#Option "ShadowFB"
#Option "rotate"
#Option "fbdev"
#Option "debug"
Identifier "Card0"
Driver "vesa"
Vendorname "nVidia Corporation"
BoardName "C79 (GeForce G102M)
Bus ID "PCI:2:0:0"

y en cuanto a la otra cuestion, si estas usando network-manager (que es el que viene por defecto osea que sí), sin entorno gráfico no tienes wifi, necesitas configurarla a mano. Lo ideal en mi opinión es que instales wicd en cuanto puedas conectar. Los restricted-extras no tienen nada que ver con la tarjeta gráfica así que de momento olvídalo. Encargate de conseguir acceder al escritorio. Cuando lo hagas, configura la conexión a internet y automaticamente instala wicd. sin tocar anda reinicias el sistema y configuras wicd para que se conecte automáticamente. De esa forma si te cargas el acceso al escritorio al intentar instalar el driver o toquetear el xorg.conf tendrás acceso a internet por wifi aunque no te arranque el entorno gráfico.

ok, pues hago lo que me dices, y con vesa, el sistema gripa, pero con nouveau arranca kbuntu pero sin escritorio, sólo consola, al hacer startx pone:

Fatal server error: no screens found.

xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.
Que mas puedo hacer? gracias.

instalar el driver desde la consola, desconozco el nombre de los paquetes en ubuntu, pero necesitaras, nvidia-glx nvidia-kernel-(tuversiondelkernel) y nvidia-xconfig. Tras instalarlos ejecutas sudo nvidia-xconfig y a rezar

$sudo aptitude install nvidia-185-kernel-source

Con esto deberia instalarse :

- nvidia-185-kernel-source
- nvidia-173-modaliases
- nvidia-96-modaliases
- nvidia-common
- nvidia-current
- nvidia-current-modaliases

y creo que también automáticamente

- nvidia-settings (equivalente de nvidia-xconfig para kde)

si no con el mismo comando lo puedes instalar.

Para saber si tienes la red conectada puedes hacer un ping:

ping kubuntu-es.org

Para pararlo presiona las teclas "Ctrl" + "C".

(PD: recuerdo que al instalar Lucid tras arrancar el sistema la pantalla se quedaba en negro porque no se instalaba automáticamente el paquete kdebase, pero no recuerdo los detalles, podrias comprobar que está instalado por si acaso)

Me he colado:

- nvidia-settings (equivalente de nvidia-xconfig para kde)

No es el equivalente, son cosas diferentes:
- nvidia-settings es la configuración ejecutada desde la interfaz
y
- nvidia-xconfig ¿es un autoconfigurador desde consola?