Tor+Privoxy+Vidalia congela firefox al habilitar tor con Torbutton [Solucionado]

Instale Tor+Privoxy+Vidalia en ubuntu 10.04, tengo el siguiente problemas.

al habilitar tor con Torbutton en firefox, este se congela y no deja entrar en la pagina, si doy abrir el enlace en una nueva ventana me manda el siguiente mensaje

el servidor proxy está rechazando las conexiones

de antemano gracias por la ayuda

Un poquito más de información ayudaría. Vamos, dice que te rechaza las configuraciones pero no sabemos cuales son. ¿Has provado sin vidalia? configurando a mano el proxy en el firefox?

la configuracion de vidalia:

general:
iniciar tor cuando inicia Vidalia

compartimiento:
ejecutar como solo cliente

Puerto de control:

direccion: 127.0.0.1:9051

/etc/privoxy/config

        forward-socks5   /               127.0.0.1:9050 .

eso es toda la configuracion que tengo

¿y has probado a configurarlo sin vidalia? ¿has leido la wiki? Nunca he usado vidalia, pero por qué ese puerto?

me guien con estos dos enlaces:
kubuntu-es , otro enlace

ya probé sin vidalia lo desinstale por completo

aptitude remove vidalia
aptitude purge vidalida

ya visite la wiki con los que encontré en ella y lo que encontré en google configure.

desinstale tor y privoxy para iniciar de nuevo. luego comentare lo resultados

Para comprobar si tor está arrancado, teclea en un terminal

ps -ef | grep tor

Cuando en Firefox tienes una página cargada y activas tor con torbutton, tienes que volver a cargar la página porque si no, no funcionan los enlaces.

Un saludo

ya instale de nuevo tor+privoxy+ vidalia y torbutton me pasa lo mismo, se congela al activar el torbutton. probe el comando que me diste y me dio la siguiente respuesta segun veo tor carga bien.

gacs@gacs-laptop:~$ ps -ef | grep tor
root      1632  1524  0 14:08 ?        00:00:01 hald-addon-storage: polling /dev/sr0 (every 2 sec)
gacs      1825  1744  1 14:08 ?        00:00:25 avant-window-navigator
gacs      1857     1  0 14:08 ?        00:00:00 /usr/lib/gvfs/gvfs-gdu-volume-monitor
gacs      1874  1825  0 14:08 ?        00:00:00 awn-applet -p /usr/share/avant-window-navigator/applets/quick-prefs.desktop -u 1 -w 23068715 -i 1
gacs      1876  1825  0 14:08 ?        00:00:14 awn-applet -p /usr/share/avant-window-navigator/applets/taskmanager.desktop -u 3 -w 23068716 -i 1
gacs      1882     1  0 14:08 ?        00:00:00 /usr/lib/gvfs/gvfs-afc-volume-monitor
gacs      1885     1  0 14:08 ?        00:00:00 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
gacs      1899  1815  0 14:08 ?        00:00:00 /bin/sh -c /usr/bin/compiz-decorator
gacs      1900  1899  0 14:08 ?        00:00:01 /usr/bin/gtk-window-decorator
gacs      1908     1  0 14:08 ?        00:00:00 bash /usr/bin/tomboy-panel --oaf-activate-iid=OAFIID:TomboyApplet_Factory --oaf-ior-fd=18
gacs      1915     1  0 14:08 ?        00:00:00 /usr/lib/gnome-panel/notification-area-applet --oaf-activate-iid=OAFIID:GNOME_NotificationAreaApplet_Factory --oaf-ior-fd=21
gacs      1916     1  0 14:08 ?        00:00:00 /usr/lib/gnome-panel/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory --oaf-ior-fd=27
gacs      1918     1  0 14:08 ?        00:00:06 python /usr/lib/gnomenu/GnoMenu.py --oaf-activate-iid=OAFIID:GNOME_GnoMenu_Factory --oaf-ior-fd=33
gacs      1922  1908  0 14:08 ?        00:00:01 mono /usr/lib/tomboy/Tomboy.exe --sm-disable --panel-applet --oaf-activate-iid=OAFIID:TomboyApplet_Factory --oaf-ior-fd=18
gacs      1934  1855  0 14:09 ?        00:00:01 /usr/sbin/tor -f /home/gacs/.vidalia/torrc DataDirectory /home/gacs/.tor ControlPort 9051 HashedControlPassword 16:0F9124182E1ACCA760C53B479D49A9EBE48F4310F9CF35FB0692AD54F0
gacs      2116     1  0 14:11 ?        00:00:00 /usr/lib/evolution/2.28/evolution-alarm-notify --oaf-activate-iid=OAFIID:GNOME_Evolution_Calendar_AlarmNotify_Factory:2.28 --oaf-ior-fd=30
gacs      2862  2843  0 14:41 pts/0    00:00:00 grep --color=auto tor
gacs@gacs-laptop:~$

cambien la configuración de privoxy de

forward-socks5   /               127.0.0.1:9050 .

a

forward-socks4a / localhost:9050 .

y ya puedo navegar bien, muchas gracia por la ayuda brindada

gacs escribió:

cambien la configuración de privoxy de

forward-socks5   /               127.0.0.1:9050 .

a

forward-socks4a / localhost:9050 .

y ya puedo navegar bien, muchas gracia por la ayuda brindada

Hola ¿Estas seguro que esa fue una solución definitiva a tu problema? ¿No habrá sido momentáneo solo por haber reiniciado privoxy luego de modificar el archivo de configuración?

Lo digo porque me está ocurriendo un problema similar al tuyo, con el mensaje "El servidor proxy está rechazando las conexiones", pero resulta que al detener y volver a iniciar (o reiniciar) privoxy, todo comienza a funcionar. Cada vez que reinicio el sistema tengo que reiniciar privoxy. Me sucede lo mismo utilizando socks5 o socks4.

Saludos.