DigiKam no recuerda mis etiquetas de antes de la última actualización [Solucionado]

Bueno, lo que dice en el título más extenso:

Actualicé de 9.10 a 10.04 LTS, el home lo tengo en otra partición e instalé desde 0 sin formatear la partición del home Tuve problemas al actualizar al principio y al instalar desde 0 después (las dos veces la compañia que suministra electrecidad decidió que era un buen momento para cortarmela por un ratito). Al abrir DigiKam me sale una ventana que dice:

/home/gurea/.kde/sare/config/digikamrc
no se puede escribir en el archivo de configuración

Intuyo que con solamente darle todos los permisos posibles podría empezar a funcionar, pero para mí es muy importante no perder el etiquetado que ya tenía hecho. Hace unos meses pasé casi un mes en casa enfermo y había etiquetado no sé cuántos miles de fotos y son muchas muchas horas de trabajo. Entonces, no quiero por toquetear a la ligera cargarme el trabajo, al menos que ya me lo haya cargado al actualizar, que espero que no sea así.

Para terminar comento, no sé si tiene alguna relación, entonces, por si acaso: Cuando enciendo me suele salir un aviso de Nepomuk que dice:
Nepomuk no encontró el motor de base de datos configurado "redland", por lo que no se puede acceder

Ahora no se me ocurre qué más contar, estoy en el trabajo y esto me pasa en la compu de casa; cuando estoy allá rara vez dispongo del tiempo que hace falta para redactar decorosamente un post, así que lo baso en anotaciones de papelitos. Si tengo que investigar algo tenerme paciencia.

Checa en la configuración de DigiKam, si has hecho copy/paste estas poniendo mal la ruta del archivo, no es sare, sino share.

/home/gurea/.kde/share/config/digikamrc

si has copiado mal revisa los premisos

ls -l /home/gurea/.kde/share/config/digikamrc

deberías poder leer y escribir en el archivo con tu usuario.

Hola, Viorel, y grácias.

Como había dicho en el primer post, estaba escribiendo a partir de lo que había copiado en papelitos, el problema lo tengo en la compu de casa y es difícil cuando estoy acá, poder ponerme a redactar o hacer algo que necesite atención continuada (un bebé y trabajo muchas-muchas horas fuera de casa)

Te hice caso e hice lo que me dijiste, el resultado:

gurea@gurea:~$ ls -l /home/gurea/.kde/share/config/digikamrc
-rw------- 1 root root 21223 2010-05-12 23:38 /home/gurea/.kde/share/config/digikamrc

Como soy medio queso para retener qué significan las ordenes de consola me fijé por dolphin, poniendo la ruta y efectivamente no puedo acceder a nada, pero ni a ese ni a ningún otro archivo de ese directorio.

Se me ocurrió llamar al DigiKam desde consola como sudo y ahí me apareció todo bien, entonces: ¿Tendría que darle derechos de lectura y escritura al grupo en ese archivo? ¿a todos?

Me tranquilizó ver que aparecían de vuelta las etiquetas, sigo con el miedo de perderlas por arreglar a medias.

Paso a intentar explicar mejor lo de cómo hice la instalación, por si importa, si no tiene importancia ni leás:
Antes comenté medio por arriba que había tenido problemas con la electricidad a la hora de instalar.

  • Antes de empezar a instalar el home lo había copiado también en otro disco, por si acaso
  • En una de las idas de electricidad se me dañaron algunnos datos de la partición del home
  • Desde el Live USB copié el respaldo del home a la partición del home.
  • Reinstalé

Antes no había explicado todo esto, pero capaz que en alguna de las idas y venidas perdí los permisos.

Es que el propietario del archivo es root.

-rw------- 1 root root 21223 2010-05-12 23:38 /home/gurea/.kde/share/config/digikamrc

cambialo por tu usuario:

cd /home/gurea/.kde/share/config
sudo chown gurea:gurea digikamrc

Y por lo que mencionas es todo el directorio, deberías hacer lo mismo con el directorio completo usando chown -R pero bueno, hay que ver el propietario de los demás archivos porque además parece que ninguna otra aplicación te da problemas.

Hago la prueba durante el fin de semana, lo de que no me dan problemas otras aplicaciones es porque, por un lado, desde que lo actualicé no es tanto lo que usé, y por otro, porque aunque Kontact y algún otro sí me problema, no quería meter muchos problemas en un post y quería dejar patente que para mí lo más urgente es no perder el trabajo en DigiKam.
Investigo y pruebo con todos los archivos del directorio.
El que no me da problemas es Amarok, se me hace raro porque también es de KDE y también lo tenía configurado-tuneado.

Reedito:
El no saber me hace decir mucha tontería, también me da problemas el ooO

Solucionado lo de DigiKam, el resto ya veremos:
Fui hasta la carpeta /home/gurea/.kde/share
Hice

$ sudo chown -R gurea:gurea config

Y listo

Para desasnarme le pregunté a google cómo funciona el comando chown y me mandó acá igualmente lo hice en base a lo que me dió Viorel [chown usuario:usuario] y no como dice en la página esa [chown -R usuario carpeta]

Mil gracias, Viorel. Ahora me sigo peliando con el resto de cosas.
Viva los fines de semána que empiezan el viernes!