Compartir impresoras [Solucionado]

Hola!
Tengo un problema con la impresora: Cada vez que reinicio el ordenador, pierdo la compartición. Tengo que reiniciar manualmente el samba. Sin embargo, las carpetas compartidas, una vez que inicio la sesión, están disponibles. La impresora sólo al reiniciar el samba.

¿Alguna idea?

Bueno, comento un poco el sistema: tengo Karmic instalada desde cero y la conexión la tengo por wifi. La impresora es una epson stylus dx4800, aunque no creo que tenga nada que ver, pues tengo instalada una cups-pdf, y me pasa lo mismo (están configuradas dentro de la máquina gnu/linux).

El problema viene, creo, desde la versión de jaunty o, incluso, intrepid (solo que no le eché cuentas, miraba la configuración, aparentemente todo estaba bien, reiniciaba samba y a imprimir). Creo que se debe a que la red se configura ahora por el network-manager, para dar más flexibilidad, no hay necesidad de utilizar la clave de administrador. De hecho en Ubuntu ya no viene el paquete system-config-samba para configurar los recursos compartidos por defecto, se utiliza el nautilus-share, de forma que no hace falta tener permisos de administrador para configurar los recursos compartidos..

El hecho de que hasta que no realizo el login no estén disponibles los recursos es comprensible: la red no queda configurada hasta que el usuario entra en la sesión, por el network-manager. Lo que no entiendo es por qué las impresoras no están disponibles hasta que reinicio el samba con

/etc/init.d/samba restart

eso sí, una vez iniciada sesión. Al reiniciar la máquina, vuelven a desaparecer las impresoras, no así las carpetas compartidas (después del login).

La configuración del samba está correcta, si no no podría imprimir una vez reiniciado el demonio...

Se me olvido... el escritorio es Gnome. Si es necesario algún fichero de configuración, lo mandaré, pero, como decía, una ejecuto el samba, todo va O.K., por lo que creo que no es exactamente del /etc/samba/smb.conf.

[global]
workgroup = workgroup
server string = %h server (Samba, Ubuntu)
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
security = share
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes
map to guest = bad user

; load printers = yes
;   printing = bsd
;   printcap name = /etc/printcap
; printing = cups
;   printcap name = cups
usershare allow guests = yes
; guest ok = no
; guest account = nobody

;[homes]
;   comment = Home Directories
;   browseable = no
;   read only = yes
;   create mask = 0700
;   directory mask = 0700
;   valid users = %S
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes
;   share modes = no
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700
[printers]
comment = All Printers
browseable = yes
path = /var/spool/samba
printable = yes
guest ok = yes
read only = no
create mask = 0700
[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
writeable = yes
guest ok = yes
;   write list = root, @lpadmin

He configurado directamente, sin network-manager, y ocurre lo mismo, hasta que no reinicio el samba no hay impresoras, eso si, las carpetas estan disponibles antes del login.. jejejejeje

Pues ya está solucionado. Sigo sin saber muy bien por qué hasta que no se reinicia el samba no me toma las impresoras, pero, bueno, os comento lo que hice:

1º Configurar la red de forma manual:

De esto hay mil documentos, es configurando el /etc/network/interfaces. Yo instalé el "network-admin", deshabilite el nm-applet de las aplicaciones de inicio, paré el servicio del network-manger con

/etc/init.d/network-manager stop

y comenté todas las lineas del /etc/init/network-manager.conf, quedando así:

# network-manager - network connection manager
#
# The Network Manager daemon manages the system's network connections,
# automatically switching between the best available.

description "network connection manager"

#start on (local-filesystems
#   and started dbus)
#stop on stopping dbus

#expect fork
#respawn

#exec NetworkManager

Despues, con el network-admin configure la red. Así siempre que se arranque la máquina nos loguemos o no, tendremos red y, por tanto, los recursos compartidos.

2º Reiniciar el samba (para que estén disponibles las impresoras):

Edité el /etc/rc.local y añadí /etc/init.d/samba restart, quedando el fichero así:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

/usr/sbin/smbd -D
/usr/sbin/winbindd -D
/usr/sbin/nmbd -D
/etc/init.d/samba restart
exit 0

También añadí las líneas que terminan en -D, pero con esto no funcionó, tengo que probar si eliminándolas va o no.

Y esto es todo amigos!!!!

Gracias por compartir la solución.

Creo que algunas cosas sobran a lo que probaste.

Al configurar el dispositivo de red en el archivo interfases ya no es necesario iniciar sesión gráfica, porque el sistema ya sabe que configuración aplicar sin necesidad de una tercera aplicación que gestione la configuración de la red.

No necesitas desactivar el Network Manager, porque al estar configurada la tarjeta de red en el archivo interfase, el Network Manager no tendrá en cuenta los dispositivos que se encuentren configurados manualmente.

Sino quieres configurar la red a mano y quieres hacerlo gráficamente puedes usar Wicd, con Wicd podrás configurar gráficamente la red como con el Network Manager, pero a diferencia de este, Wicd te permite tener red sin iniciar sesión gráfica, osea prendes el PC y sin iniciar sesión en una TTY o gráficamente ya tendrás red, lo mismo que si configuraras la red en el archivo interfases.

Podrías probar dejando los archivos que modificaste como estaban antes e instalar Wicd y hacer la prueba si quieres para probar si con el te funciona lo que querías hacer

Saludos.

Probe a configurar el interfaces sin desactivar el network-manager y no me funcionaba la red, era incapaz de validar la clave wep, aunque el dispositivo si cogía la ip estática, (con la dinámica fallaba), no podía hacer ping al router. Tuve que desactivarlo para que realmente conectara (ahora tanto dinámica como estática), con lo que el network-manager, aunque no debería, se solapa con el interfaces....

La primera vez sólo pare el demonio pero, al reiniciar, volví a quedarme sin red, así que paré el demonio y lo desactivé y se eliminaron los problemas de red.

Es posible que sea algún tipo de error o que ocurra solo con algunas tarjetas, la mía tiene un chip rtl8187b y detecta dos dispositivos: el wlan0 y wmaster0, pero en el segundo no se configura nada ni en interfaces ni con el network-manager (al menos a simple vista)

Probé con otra tarjeta que lleva el rtl8187 y le pasaba lo mismo: dos dispositivos (eso no es nuevo de karmic), y sin posibilidad de configurar hasta desactivar el network-manager.....

Lo del samba con las impresoras siguió pasando hasta que añadí el reinicio del demonio al rc.local.

hola yo no se mucho de esto escasos 6 meses llevo en gnu/linux usaba ubuntu 8.04 y todo iva bien con samba pero como no use la version 9.04 no se si el problema biene ahi me brinque de ubuntu 8.04 a 9.10 y empece a tener los problemas de que no muestra las impresoras pero si las carpetas...
mi mother es intel es de escritorio... me podrias decir donde añado el reinicio del samba...

perdon ya lo solucione con lo que dijiste...

/usr/sbin/smbd -D
/usr/sbin/winbindd -D
/usr/sbin/nmbd -D
/etc/init.d/samba restart
exit 0