Problemas con NVIDIA en mi laptop COMPAQ CQ-60 [Solucionado]

Hola!, acaba de llegar a mis manos mi nueva compaq presario cq60

La computadora es esta:

http://www.bestbuy.com/site/olspage.jsp?skuId=9454253&type=product&id=12...

Mi principal problema es que la placa de video nvidia no funciona, cuando instalo los drivers oficiales el monitor aparece dividido en 6 partes y dice tener una resolucion de 640x480. Pero apenas es manejable.
Alguién sabe solucionarlo? Gracias! Este problema lo tuve tanto con MANDRIVA, cómo con UBUNTU, instalando drivers oficiales.

Hice este comando con este resultado:

gatillo@gatillo-laptop:~$ lspci | grep -i nvidia

00:00.0 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation Device 075e (rev a2)
00:01.1 SMBus: nVidia Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.3 Co-processor: nVidia Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: nVidia Corporation MCP78S [GeForce 8200] High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP78S [GeForce 8200] Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:14.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8200M G (rev a2)

Probé de instalar tanto UBUNTU 9.04 cómo también MANDRIVA 2009 de 64 bits con drivers oficiales y los que están en los paquetes. En ambos casos la pantalla del laptop aparece dividida en 6 partes, en las cuáles se repite la imagen, en teóricos 640x480.

Me ayudan por favor?

http://www.kubuntu-es.org/wiki/comenzando/howto-conociendo-sistema-o-com...

La sección de video es la que, especialmente en esta ocasión, te será útil.

Saludos.

dinos de que forma instalas el 'controlador oficial' .. y si estas seguro que el controlador está bien instalado has chequeado las configuraciones de tu archivo /etc/X11/xorg.conf y de las opciones del programa de gráficas nvidia?

Hola, me acabo de dar cuenta que con la instalación del driver oficial no bajé los drivers de la página sino que instaló los de ubuntu. Esto es porque no sé cómo conectarme a internet sin entorno gráfico (Agradecería instrucciones, la red inalámbrica tiene clave wpa2 creo).
Desde línea de comando, luego de parar X, ejecuto:
sudo ./NVIDIA-Linux-x86_64-185.18.36-pkg2
Ahora bien, al margen de ello, mi xorg.conf es demasiado simple (mi anterior compu, con placa intel 915 tenía un xorg.conf muchísimo más largo que el que les voy a mostrar). El archivo xorg.conf es el siguiente:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Section "Module"
Load "dri"
Load "GLcore"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "NoLogo" "True"
Driver "nv"
EndSection

Y con este xorg.conf aparecen las 6 minipantallitas :S
Por suerte aprendí que con

sudo dpkg-reconfigure -phigh xserver-xorg

puedo volver a la "normalidad", esto es a usar el VESA en lugar del nvidia cómo driver. La normalidad es 1280x720 y no 1366x768, la cual es la verdadera resolución del monitor.

Muchas gracias!!

Me imagino que mi problema está en este archivito!!
Gracias!!!

Creo que no leíste esta parte del enlace que recomendé:

[...] es necesario usar las etiquetas de código para facilitar la lectura de la información que se le haya solicitado, lo anterior porque a veces es demasiado extenso el texto y la lectura podría dificultarse si no se usan las etiquetas de código. Por lo tanto al momento de pegar el texto con la información que se le haya solicitado, el usuario debe seleccionar dicha información y oprimir el botón de código (.c), el cual se encuentra en la barra de herramientas visible al momento de la redacción [...]

http://www.kubuntu-es.org/wiki/comenzando/howto-conociendo-sistema-o-com...
http://www.youtube.com/watch?v=y1nClTbA0Vc

siddharta escribió:

Creo que no leíste esta parte del enlace que recomendé:

Clic en la imagen para ver un video de como insertar código:
Etiqueta Codigo

Gracias, ahí corregí el recuadro.

despues de instalar el driver de la pagina de nvidia, te pregunta si quieres ejecutar nvidia-xconfig y no lo has hecho, si no tu xorg.conf seria mas completo, ejecutalo

sudo nvidia-xconfig

Hola!, les detallo lo que hice:

gatillo@gatillo-laptop:~$ sudo /etc/init.d/gdm stop
gatillo@gatillo-laptop:~$ ./NVIDIA-Linux-x86_64-185.18.36-pkg2.run

Primer error, no puede bajar de NVIDIA las cosas. Esto es porque tengo red inalámbrica, y para conectarme yo dependo del entorno gráfico (por ignorancia). Por eso compila con las cosas que bajé de ubuntu.
Ahí instala los drivers y me da la opción para que solito haga

sudo nvidia-xconfig

Igual, una vez que terminé, probé (arranqué el gdm) y tenías las 6 minipantallas. Por lo que volví a parar gdm y puse en consola el nvidia-xconfig sin cambios.
El xorg.conf de nvidia es este:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Fri Aug 14 18:33:37 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

En chiquito veo que los efectos de compiz se activan, así que aceleración 3d debo tener, me parece que lo que no comprende es al monitor. Igual, confío en Uds, y les agradezco cualquier ayuda!
Para gente con problemas similares al mío es fundamental tener a mano el comando:

sudo dpkg-reconfigure -phigh xserver-xorg

Porque sin el la ignorancia te lleva a reinstalar todo otra vez más. Ese comandito me ahorro 3 o 4 instaladas de linux.
Muchas gracias!!

Hola.
Fijate si encuentras algo aquí:
http://www.google.com/search?hl=es&q=%22nvidia%22+%22six+screens%22+%22u...

Especialmente en esta:

http://jens.yelles.se/2009/07/02/drivers-for-nvidia-geforce-g105m

y el mensaje #12 de "kevinttl":

http://www.nvnews.net/vbulletin/showthread.php?t=132041

En Section “Device” y Section “Screen”.

Suerte!

Hola, muchas gracias, no es muy bueno mi inglés pero leeré lo que pueda para ver si puedo hacer algo. Ya intenté agregar en mi las líneas que correspondían, dejándolo así:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUO"
#    HorizSync       30.0 - 100.0
#    VertRefresh     55.0 - 110.0
#    DisplaySize 344 193
#    Mode "1366x768"
# DotClock 69.5MHz
# HTimings 1366 1414 1446 1437
# VTimings 768 771 775 806
#    EndMode
# Modeline "1366x768"   69.50  1366 1414 1446 1437  768 771 775 806
Modeline "1366x768"   69.50  1366 1414 1446 1473  768 771 775 806 -hsync -vsync
# Modeline "1366x768q"   72.00  1366 1414 1446 1494  768 771 777 803 -hsync -vsync
#    Option "DPMS" "True"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    SubSection     "Display"
Modes "1366x768"
        Depth       24
    EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Mi resultado lamentablemente siguen siendo las 6 pantallitas. Voy a ver si encuentro otra forma de arreglarlo. Si a alguien se le ocurre algo, o lee mejor el inglés que yo. Muchas gracias!