eliminar el kernel 2.6.28-15 generic [Solucionado]

Actualicé de 8.04 a 8.10. Me llevó tres horas hacerlo vía internet, porque no había imagen iso que me sirviera. Luego actualice de 8.10 a 9.04 que es en realidad la versión que quería instalar y no podía. (Me llevó tres horas más) Lo que ocurrió es que me fuía a dormir mientras actualizaba. Al día siguiente, Kubuntu me estaba esperando para que contestara no me acuerdo qué. Le dí OK. y se terminó de instalar luego de unos 30 minutos más.
Aparentemente todo anda bien (excepto por algunos problemas menores con el reloj y la impresora que ya voy a arreglar con tiempo) El único problema que tengo y me molesta, es que se instalaron dos kernel que son los siguientes:
kernel 2.6.28-15 generic que es el que se ejecuta por defecto y hace que se cuelgue la compu antes que se cargue.
y el kernel 2.6.24-23 generic que es el que anda.
Mi pregunta es: ¿Hay una manera de eliminar el primer kernel para que no tenga que estar al lado de la compu para hacer arancar manualmente el kernel que anda?

Espero que me haya explicado bien. Si no, espero que sepan disculpar mi ignorancia. Apenas hace dos meses que me inicié en Linux y la única razón que sigo es que para hacer lo que hago con linux, en windows, necesitaría comprarme una nueva compu y un nuevo windows. Gracias por su ayuda.

Muchas gracias Tuxerito; intenté hacer todo esto, reinicié y el kernel sigue ahí. ¿No habrá una mejor manera de hacerlo?
Igualmente sigo investigando.
Gracias!!!

Podrías ejecutar los comandos y colocar aquí lo que estas ejecutando y lo que te devuelve la consola, así los demás podrían ver cual puede ser el problema.

Tuxerito escribió:

Podrías ejecutar los comandos y colocar aquí lo que estas ejecutando y lo que te devuelve la consola, así los demás podrían ver cual puede ser el problema.

El mensaje es para hora...
El comando que se refiere Tuxerito es éste:

$ dpkg --get-selections | grep linux-image

esto es lo que sale cuando ejecuto el comando sugerido

linux-image-2.6.24-23-generic                   install
linux-image-2.6.27-14-generic                   deinstall
linux-image-2.6.28-15-generic                   install
linux-image-generic                             install

lo que me gustaría, es desinstalar el 2.6.28-15-generic , porque no me funciona. Mientras que el otro sí me funciona.

hora escribió:

esto es lo que sale cuando ejecuto el comando sugerido

linux-image-2.6.24-23-generic                   install
linux-image-2.6.27-14-generic                   deinstall
linux-image-2.6.28-15-generic                   install
linux-image-generic                             install

lo que me gustaría, es desinstalar el 2.6.28-15-generic , porque no me funciona. Mientras que el otro sí me funciona.

Eliminalo así:

# aptitude purge linux-image-2.6.28-15-generic

Si no sos root, anteponé sudo

Me parece bien que trates de eliminar el kernel si no te funciona, pero si no lo consigues, puedes elegir qué kernel arranca por defecto en /boot/grub/menu.lst

Modificando el valor del parámetro default indicas qué entrada es la que se arranca por defecto. Aquí tienes más datos:
http://www.kubuntu-es.org/foro/200803/manual-instrucciones-grub

Otra cosa interesante sería averiguar por qué no te funcione ese kernel y tratar de encontrar una solución, porque el kernel que te funciona es bastante antiguo...

Un saludo

stalker escribió:

Otra cosa interesante sería averiguar por qué no te funcione ese kernel y tratar de encontrar una solución, porque el kernel que te funciona es bastante antiguo...

Eso mismo estaba pensando yo, no serà que entre tanta actualizacion quedaron paquetes a medio instalar ?
Talvez la solucion sea algo tan simple como reparar paquetes rotos o dependencias incumplidas.

Para intentar solucionarlo teclea en un terminal:

sudo dpkg --configure -a

para configurar los paquetes parcialmente instalados

Despues

sudo aptitude update

para actualizar la lista de paquetes de los repositorios

y

sudo aptitude install -f

para solucionar problemas de dependencias incumplidas

Gracias a todos por sus aportes. les cuento qué hice anoche y luego me fuí a dormir, cansado de "renegar". Lo primero que hice fue usar el comando sugerido que es el siguiente: # aptitude purge linux-image-2.6.28-15-generic.
Me funcionó muy bien ya que reinicié la máquina y entró directamente en el kernel que anda. Sólo que ya no entraba, sino que se me colgaba. Volví a reiniciar y entré con el kernel que repara paquetes rotos. Me salió un cartel en inglés de actualización (creo). Le di el OK con la "Y" y... ¡Sorpresa! apareció nuevamente el kernel borrado (por supuesto, luego de un rato de estar actualizando) 10 minutos.
Me interesa quedarme con el kernel más nuevo que halla. Así que ahora me dispongo a intentar lo que me sugiere stalker.
Sigo informando. Pues no me daré por vencido :)

esto es lo que hice y lo que salió:

hora@KUBUNTU:~$ sudo dpkg --configure -a
[sudo] password for hora:              
hora@KUBUNTU:~$ sudo aptitude update   
Escribiendo información de estado extendido... Hecho
Obj http://security.ubuntu.com jaunty-security Release.gpg
Obj http://ar.archive.ubuntu.com jaunty Release.gpg             
Des:1 http://ar.archive.ubuntu.com jaunty/main Translation-es [608kB]
Ign http://security.ubuntu.com jaunty-security/main Translation-es  
Ign http://security.ubuntu.com jaunty-security/restricted Translation-es
Ign http://security.ubuntu.com jaunty-security/universe Translation-es 
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-es
Obj http://security.ubuntu.com jaunty-security Release                 
Obj http://security.ubuntu.com jaunty-security/main Packages           
Obj http://security.ubuntu.com jaunty-security/restricted Packages     
Obj http://security.ubuntu.com jaunty-security/main Sources            
Obj http://security.ubuntu.com jaunty-security/restricted Sources      
Obj http://security.ubuntu.com jaunty-security/universe Packages       
Obj http://security.ubuntu.com jaunty-security/universe Sources        
Obj http://security.ubuntu.com jaunty-security/multiverse Packages     
Obj http://security.ubuntu.com jaunty-security/multiverse Sources      
Des:2 http://ar.archive.ubuntu.com jaunty/restricted Translation-es [4921B]
Des:3 http://ar.archive.ubuntu.com jaunty/universe Translation-es [1270kB]
Des:4 http://ar.archive.ubuntu.com jaunty/multiverse Translation-es [106kB]                                                    
Obj http://ar.archive.ubuntu.com jaunty-updates Release.gpg                                                                    
Ign http://ar.archive.ubuntu.com jaunty-updates/main Translation-es                                                            
Ign http://ar.archive.ubuntu.com jaunty-updates/restricted Translation-es                                                      
Ign http://ar.archive.ubuntu.com jaunty-updates/universe Translation-es                                                        
Ign http://ar.archive.ubuntu.com jaunty-updates/multiverse Translation-es                                                      
Obj http://ar.archive.ubuntu.com jaunty Release                                                                                
Obj http://ar.archive.ubuntu.com jaunty-updates Release                                                                        
Obj http://ar.archive.ubuntu.com jaunty/main Packages                                                                          
Obj http://ar.archive.ubuntu.com jaunty/restricted Packages                                                                    
Obj http://ar.archive.ubuntu.com jaunty/main Sources                                                                           
Obj http://ar.archive.ubuntu.com jaunty/restricted Sources                                                                     
Obj http://ar.archive.ubuntu.com jaunty/universe Packages                                                                      
Obj http://ar.archive.ubuntu.com jaunty/universe Sources                                                                       
Obj http://ar.archive.ubuntu.com jaunty/multiverse Packages
Obj http://ar.archive.ubuntu.com jaunty/multiverse Sources
Obj http://ar.archive.ubuntu.com jaunty-updates/main Packages
Obj http://ar.archive.ubuntu.com jaunty-updates/restricted Packages
Obj http://ar.archive.ubuntu.com jaunty-updates/main Sources
Obj http://ar.archive.ubuntu.com jaunty-updates/restricted Sources
Obj http://ar.archive.ubuntu.com jaunty-updates/universe Packages
Obj http://ar.archive.ubuntu.com jaunty-updates/universe Sources
Obj http://ar.archive.ubuntu.com jaunty-updates/multiverse Packages
Obj http://ar.archive.ubuntu.com jaunty-updates/multiverse Sources
Descargados 1988kB en 12s (157kB/s).
Leyendo lista de paquetes... Hecho
Actualizando la base de datos de etiquetas...... Hecho

ahora voy a ejecutar el otro comando sugerido y veo qué pasa.