Resolucion de Pantalla Kubuntu 9.04 tarjeta intel[Solucionado]

Hola a Todos.

El dia de ayer por fin di el primer paso para migrar de windows, y mi elección final fue kubuntu 9.04.

La instalación fue de las mas sencillas que hice después de haber probado Knoppix, OpenSuSe, PCLinuxOS.

Pero al ponerme a tratar de configurar con mis escasos conocimientos en lo referente a Linux, me encontré con el problema de la resolución de pantalla.

El problema es que la máxima resolución que me permite Kubuntu es de 800x600. Cuando en realidad mi Pc Soporta 1024x768.

Captura Resolución Máxima que me permite Kubuntu: http://www.imagechile.net/img/img8_1252910326d.GIF

Datos PC:

Procesador: Intel Pentium 4 2.8 Mhz
Placa Base: Intel La Crosse D865GLC
Tarjeta gráfica(Integrada): Intel(R) 82865G Graphics Controller (96 MB)
Monitor: Compaq MV540
Version de kernel:
Sistema de Escritorio:

Pues Para comenzar a resolver mi problema por mis medios con ayuda de otros hilos de referencia, di con el siguiente:

http://www.kubuntu-es.org/foro/200907/como-agregar-resoluciones-pantalla

Cuyo caso me pareció igual al mio, pero conforme fui realizando los pasos ahí descritos me encontré con una serie de diferencias y dificultades que no pude afrontar.

Las Cuales Describo a Continuación:

En mi xorg.conf aparece lo siguiente:

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "ServerFlags"
Option "DontZap" "True"
EndSection

Que es muy diferente al del ejemplo anteriormente citado.

Después me dije: "Que sucederá si modifico mi Xorg igual que el del ejemplo y con los mismos cambios que lo llevaron a la resolución del problema", pues al comienzo paresia buena idea pero al intentar guardar la configuración me apareció el siguiente mensaje:

"El Documento no se ha podido guardar, por que no fue posible escribir en /etc/X11/xorg.conf

Compruebe que tiene permiso de acceso a este fichero o si suficiente espacio disponible en el disco"

Captura del mensaje de error: http://www.imagechile.net/img/img2_1252910294j.GIF

Y pues ahí ya no supe que mas hacer. Por eso posteo aquí esperando que puedan brindarme su ayuda.

Bueno Para Terminar algunas capturas de pantalla:

Escritorio: http://www.imagechile.net/img/img9_1252910232f.GIF

Navegador: http://www.imagechile.net/img/img3_1252910269s.GIF <--- es muy incomodo navegar con esa resolución.

Espero haber aportado los datos necesarios, y disculpen el post tan largo.

Para guardar los cambios en el xorg.conf necestas permisos de administrador:

Editando desde terminal:

sudo nano /etc/X11/xorg.conf

ó con Kate en el entorno gráfico:

kdesudo kate /etc/X11/xorg.conf

Esto en una terminal claro (konsole).

Revisa también la sección de preguntas frecuentes del foro, seguro te es de ayuda en algo wink
Un saludo.

Como te ha comentado Viorel, el tema de los permisos es de facil solución, siguiendo sus pasos podrás editar y guardar ese archivo sin problemas.

Respecto a lo otro, pues resulta que la tendencia hacia la automagia que se lleva en los sistemas debian, hace que ahora el sistema funcione incluso si borras el archivo xorg.conf, hal se encarga de autodetectar la tarjeta grafica, monitor. perifericos etc. Por eso tu xorg.conf parece tan vacio, de hecho si lo dejas vacio no notarás la diferencia y el sistema arrancará igual.

El problema, es que la automagia no siempre funciona como uno desea, por eso se mantiene ese archivo de configuración, para "forzar" parámetros cuando la detección falla. Así que puedes modificarlo para dejarlo a tu gusto, pero no copies exactamente el ejemplo que has visto (puesto que puede que haya algún parámetro que no se ajuste a tu sistema, basta con que copies lo referente a las resoluciones en su consiguiente subsección).
En ese ejemplo, si te fijas, Viorel ha puesto el "identifier" que tiene en su sistema, no el genérico que traes tu, por lo que si lo copias tal cual puede que te falle, el xorg.conf tiene que tener su estructura y consistencia:

tu xorg.conf:

Citar

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "ServerFlags"
Option "DontZap" "True"
EndSection

la respuesta de Viorel en el otro hilo:

Citar

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection

EndSection

ves a lo que me refiero? basta con que añadas la subseccion display (en cursiva) sin modificar nada más, porque si modificas el identifier no va a coincidir con el resto de tu xorg.conf. Espero haberme explicado bien.

Saludos y suerte con tu problema!

Pues Gracias por su ayuda Viorel y shaola.

He Realizado los que comento shaola de agregar la Subseccion display, pero al guardar y reiniciar no ahí cambio alguno en la resolución ni me aparece otra resolución en Preferencia de Sistema/Pantalla.

Asi es como queda:

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
SubSection "Display"
        Viewport 0 0
        Depth 24
        Modes "1024x768"
EndSubSection
Device "Configured Video Device"
EndSection

Pero Revisando otros Hilos encontré este:

http://www.kubuntu-es.org/foro/200906/no-puedo-cambiar-resolucion-pantal...

Y Pues Me Dio la idea De Agregar en otra sección:

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
Gamma 1.0
EndSection

Aun que en lugar de:

modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync

Cambiarle a "Modeline "1024x768@60"

Reinicie pero no hubo cambio alguno, así que genere una linea para el modeline desde consola con como mencionan en el hilo "No puedo cambiar la resolución de pantalla".

gtf 1024 768 60

Copie la 2 linea que me dio en el Xorg, Guarde y Reinicie.

Y al entrar Nuevamente la resolución cambio a 1024x768. Y en Preferencia de Sistema/Pantalla Me apareció por fin la Resolución de 1024x768.

Al Final Mi Xorg.Conf Quedo de esta manera:

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
Modeline "1024x768_60.00"  64.11  1024 1080 1184 1344  768 769 772 795  -HSync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "ServerFlags"
Option "DontZap" "True"
EndSection

Así que puedo dar mi problema por Solucionado.

Nuevamente Gracias a Viorel y Shaola por la ayuda que me dieron ya que sin sus consejos no podría a ver solucionado esto. Sin olvidar a los demás miembros de esta comunidad que ayudan a otros como yo que tenemos problemas.

Genial, mis felicitaciones. ahora solo te queda marcar el hilo como solucionado:

Clic en la imagen para ver un video de como marcar un hilo solucionado:
Marcar hilo solucionado

y la proxima vez intenta evitar poner la palabra ayuda en el titulo
saludos!

Usuarios como tú, que se esfuerzan sinceramente por buscar la solución al problema, merecen nuestra felicitación.

Saludos.

Felicidades, un gusto ver tu actitud y las ganas no solo con que has planteado el problema (que nos hemos dado cuenta de tan solo verlo) sino por como te has conducido hasta encontrar la solución.

Nuevamente felicidades wink

Agregué un enlace a este tema, como buen ejemplo real de cómo solicitar ayuda en el foro, de la sección Comenzando en el Wiki:

http://www.kubuntu-es.org/wiki/comenzando/ejemplos-solicitar-ayuda-foro