La webcam da una imagen verde en skype [Solucionado]

Supongo que será una tontería, pero, al no saber diagnosticarla, tampoco puedo intentar resolverla. Busqué soluciones en éste y otros foros con skype video, no encontré nada.

La webcam:
* sí funciona bien con un tal cheese web cam que supongo que se me habrá instalado con gnome
* con skype sale verde la imagen
* según los dos programas esta es una USB Camera (046d:08af) (/dev/video0)
* la marca es logitech

La webcam me la compró mi vieja para poder ver a su primer y único nieto (mi primer y único hijo) para ciber-reducir los 12000 kilometros. En ningún lado decia que fuese compatible con Linux, pero, tampoco lo decían ni el teclado, ni el mouse, ni la impresora, ni...

Bue, espero que me puedan guiar un poco, pasado mañana tengo que intentar conectarme por skype y presentarle las nuevas monerías del querubín.

los parametros de video de la webcam estan en unos archivos en la carpeta /sys/class/video4linux/video0

en mi caso por ejemplo, funciona bien con skype, pero si arranco con camorama se ve de un color extraño, y tengo que añadir un filtro de corrección de color para que funcione bien.
antes de añadir ese filtro, el contenido del archivo /sys/class/video4linux/video0/colour es 7FFF y tras añadir el filtro es 7F00, los tiros van por ahí. abre con el cheese y comprueba el contenido de ese archivo, y luego lo abres con skype y mira a ver si ha cambiado y nos lo comentas.

Hola, también tenía ese problema. Si bien estoy usando Ubuntu con Gnome, supongo que la solución será igual. En una consola copia esto (como usuario normal): LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype
Eso lanza Skype con cámara ok. Al menos a mí me funciona. No sé hacerlo de otra forma que no sea por consola. A lo mejor alguien que sepa más puede ayudar a pasar esos datos a la configuración del programa.
Suerte y saludos.

Antes que nada, gracias por contestar, sigo:

No encontré el archivo que me decís, Shaola, esto es lo que hay

gurea@gurea-desktop:/sys/class/video4linux/video0$ dir
dev  device  index  name  power  subsystem  uevent

device, power y subsistem son directorios y en ninguno de esos aparece el archivo, en subsystem, eso sí, hay una carpeta que se llama video0 que tiene identicos contenidos y en su carpeta subsystem tiene una carpeta video0... así en adelante, me dejé de toquetear, me asustó.

por si acaso intenté probar la camara en skype con el cheese abierto,se cerró de prepo.

También probé lo que dice Huakanaum: no le importó siguió en verde...

Ah! por si acaso, ahora estoy usando 9.04 en una computadora con amd64, no tengo idea si esto es importantísimo o una tontería tal como decir que ahora tengo la CPU arriba del escritorio, pero, así es ser ignorante.

dentro de esa carpeta haz un ls en lugar de dir a ver que te dice

Te hago caso, y, lo reconozco, soy ignorantísimo y voy a ciegas, intento explicar lo que veo, así que supongo que capaz que explique de más.

gurea@gurea-desktop:/sys/class/video4linux/video0$ ls
dev  device  index  name  power  subsystem  uevent
gurea@gurea-desktop:/sys/class/video4linux/video0$

Las palabras device y subsystem salen en un color celste o"cyanoso", la palabra power en azul.

-----

me google-desasné un poco, ls es la lista (obvio, lo sé, pero no lo sabía), como soy de los usuarios normalísimos, pero que empezó con DOS, todavía me acuerdo alguna orden, por ejemplo "dir".

mira a ver dentro de device a ver si encuentras algún archivo por ahí, se escapa un poco de mis conocimientos, yo probaría a crear el archivo colour a mano, pero primero mira a ver si lo localizas por algún subdirectorio, ten en cuenta que en esa carpeta mientras no uses sudo no corres peligro de romper nada osea que busca y muevete sin miedo.

EDITO: has probado la camara con camorama? pruebala y mira a ver si puede ponerle el filtro de color

Quan escribió:

[...] ls es la lista (obvio, lo sé, pero no lo sabía)[...]

Yo siempre uso el comando ls así:

$ ls -F -h -l --group-directories-first --color=auto
total 17M
drwxr-xr-x  2 sbuda sbuda 4.0K 2009-04-22 17:19 info_files/
drwxr-xr-x 17 sbuda sbuda 4.0K 2009-08-18 12:17 nmap-5.00/
-rwxrwx---  1 sbuda sbuda  100 2009-04-22 16:51 home.desktop*
-rwxrwx---  1 sbuda sbuda  22K 2009-04-22 16:51 info.html*
-rwxrwx---  1 sbuda sbuda 1.2K 2009-08-18 12:07 installation-steps*
-rwxrwx---  1 sbuda sbuda 6.5M 2009-04-22 16:51 nmap-4.76.tgz*
-rw-r--r--  1 sbuda sbuda 9.5M 2009-08-18 12:10 nmap-5.00.tgz

de esta manera siempre veré una diagonal al final de los nombres que son directorios; el tamaño de los archivos lo veré en KB, MB, GB; y siempre estarán en primer lugar de la lista los directorios, además de mostrarse todo en diversos colores.

Para no tener que escribir siempre todos esos parámetros puedes crear un alias al final de tu archivo ~/.bashrc :

alias ls='ls -F -h -l --group-directories-first --color=auto'

y para que tenga efecto inmediato ejecuta:

source ~/.bashrc

y ahora cada vez que ejecutes ls se hará con el alias que creaste. Si quieres ver también los archivos ocultos entonces usarás:

ls -a

Más ayuda:

ls --help

Hola de vuelta.
Nuevamente lo reconozco, soy un queso.

Sigo con todo como antes pero sé y puedo decir más cosas que antes:
1) Probé el "camorama" ese, al llamarlo me dice Unable to capture image y se ve un pelín de ruido
2) Skype y Chese Webcam siguen igual
3) Me terminé dando cuenta de que el contenido de la carpeta, en realidad no es el de esa carpeta porque alguna de estas es un acceso directo (reconozco que es torpe de mi parte no darme cuenta, y pretendo disculparme diciendo que, al cambiar a KDE4 y mostrar siempre por detalles con árbol, no reconocía los íconos como accesos directos)
a) hasta /sys/class/video4linux todas las carpetas existen
b) la "carpeta" video0 es un acceso directo, no entiendo como ver especificamente a dónde, dice tener 7 elementos. Para ver a dónde manda probé con propiedades desde Dolphin (si puedo voy por modo gráfico, porque los torpes lo sentimos más tangible, como bien sabrán) y me salió algo parecido a lo que me salio haciendo

ls -F -h -l --group-directories-first --color=auto

como dijo Siddharta.

gurea@gurea-desktop:/sys/class/video4linux/video0$ ls -F -h -l --group-directories-first --color=auto
total 0
drwxr-xr-x 2 root root    0 2009-08-20 22:34 power/
-r--r--r-- 1 root root 4,0K 2009-08-20 22:34 dev
lrwxrwxrwx 1 root root    0 2009-08-20 22:34 device -> ../../../5-1/
-r--r--r-- 1 root root 4,0K 2009-08-20 22:34 index
-r--r--r-- 1 root root 4,0K 2009-08-20 22:34 name
lrwxrwxrwx 1 root root    0 2009-08-20 22:34 subsystem -> ../../../../../../../class/video4linux/
-rw-r--r-- 1 root root 4,0K 2009-08-20 22:34 uevent

en azul
power/
../../../5-1/
../../../../../../../class/video4linux/

en celeste
device
subsystem

4) antes de darme cuenta de esto de los accesos directos me había asustado un montón con las carpetas y documentos que se me repetían hasta el infinito mientras buscaba el archivo colour en device o algún otro

5) por si acaso ejecuté la misma orden en la carpeta video4linux (me da la sensación de que acá confirmarán lo duro que puedo ser de entendederas

gurea@gurea-desktop:/sys/class/video4linux$ ls -F -h -l --group-directories-first --color=auto
total 0
lrwxrwxrwx 1 root root 0 2009-08-20 22:34 video0 -> ../../devices/pci0000:00/0000:00:13.0/usb5/5-1/video4linux/video0/

en celeste
video0

en azul todo el resto

Finito.
Muchas gracias por el caso que me hacen y la paciencia que me tienen.

Después de un ratazo y de haberme dado por vencido, lo resolví más o menos.
Vi que éste dispositivo da problemas en bastantes sitios:
ID 046d:08af Logitech, Inc. QuickCam Easy/Cool (esas con forma de bolita)

Bue, con Skype no se puede resolver (o si se puede no lo encontré en ningún lado) pero sí parece que se consigue que funcione con emesene, aunque yo no lo conseguí; yo conseguí que con Kopete me funcione en yahoo mesenger, aunque no consigo que se escuche. y:

Funciona con aMSN, permite hacer video llamada y que la abuela sudamericana vea al nieto europeo.

Tenía mala onda a usar mesenger, pero consigue que funcione la camara, que, de ultima, eso es lo importante (que la abuela pueda ver al nieto)

Feliz año

_____________________

Si hubiera alguna manera de marcarlo como "relativamente solucionado" esa debería ser la etiqueta, porque yo lo que planteaba era que salía verde en Skype, y sigue saliendo verde en Skype a día de hoy (10-01-10), pero sí solucioné mi necesidad inmediata de comunicarme con mi vieja, entonces mi necesidad si está solucionada.
Prefiero que lo que planteo como problema termine con la etiqueta de solucionado, si el moderador cree que tendría que no marcarse, desmarquelo no más.

para que te funcione con emesene:
http://www.esdebian.org/foro/36780/emesene-recuadro-login-bloqueado-gris...

y respecto al skype.. ¿has probado con preload manager?