Interferencia / Ruido en Amarok al usar Firefox [Solucionado]

Saludos a todo mundo!

Tengo el siguiente problema:

Si escucho música con Amarok (2.1.1), y abro firefox (3.0.11), al hacer "Scrolling" o click, o al cambiar de pestaña, etc, el sonido de la música se ve alterado momentáneamente, como si el archivo estuviera "rayado", dañado, como si se perdiera la continuidad del sonido. Es como si las gráficas estuvieran interfiriendo con el sonido. Los archivos en realidad no están dañados, porque si regreso el Amarok para reproducir nuevamente la parte del efecto, y dejo quieto el mouse, entonces no hay interferencia y la canción suena muy bien. Esto me ocurre con cualquier canción y lo puedo repetir en todo momento. (y es muuy molesto para mí, que estoy medio neurótico)

Información:
Aunque puede leerse en mi firma, escribiré más datos de mi pc:
Hardware:
Procesador AMD Phenom II X4 955
Tarjeta gráfica MSI ATI RADEON HD 4830
Tarjeta Madre GIGABYTE GA-MA790FXT-UD5P
2 GB DDR3 Kingston.

Sistema: Kubuntu 9.04 desktop, 64 bits,

uname -r
2.6.28-14-generic

Repositorios:
backports de Jaunty (Amarok), experimental KDE (ppa launchpad, Kde4.2.96 {4.3RC2}), medibuntu (los codecs típicos para reproducir formatos privados de audio, video y dvd's), y todos los de la pestaña de actualizaciones (incluidas actualizaciones no publicadas).
Tengo instalado el plugin de Adobe (flashplugin), y me puse a instalar varios paquetes que tenían algo que ver con pulse(audio).

Configuración: (al respecto, todo default, el sonido es el integrado de la Motherboard)

lspci | grep -i audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
sudo lshw | grep -i audio | grep product
product: HD48x0 audio
lsmod | grep -i snd
snd_hda_intel         557492  8
snd_pcm_oss            52352  0
snd_mixer_oss          24960  1 snd_pcm_oss
snd_pcm                99336  3 snd_hda_intel,snd_pcm_oss
snd_seq_dummy          11524  0
snd_seq_oss            41984  0
snd_seq_midi           15744  0
snd_rawmidi            33920  1 snd_seq_midi
snd_seq_midi_event     16512  2 snd_seq_oss,snd_seq_midi
snd_seq                66272  7 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              34064  3 snd_pcm,snd_seq
snd_seq_device         16276  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    78792  24 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              16800  1 snd
snd_page_alloc         18704  2 snd_hda_intel,snd_pcm
pulseaudio -nC                                                                                                 
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.                                                                           
I: caps.c: Dropping root privileges.                                                                                                    
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.                                                                           
N: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:                                                                                                                                     
N: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.                                                                                                                          
N: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.                                                                   
E: pid.c: Daemon already running.                                                                                                             
E: main.c: pa_pid_file_create() falló.
aplay -l
**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: SB [HDA ATI SB], dispositivo 0: ALC883 Analog [ALC883 Analog]
  Subdispositivos: 0/1
  Subdispositivo #0: subdevice #0
tarjeta 0: SB [HDA ATI SB], dispositivo 1: ALC883 Digital [ALC883 Digital]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
tarjeta 1: HDMI [HDA ATI HDMI], dispositivo 3: ATI HDMI [ATI HDMI]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

(Gracias Siddharta!)
En preferencias del sistema>Multimedia:
Salida de audio (todos):
HDA ATI SB (ALC883 Analog)
HDA ATI HDMI, ATI HDMI (HDMI Audio Output)
PulseAudio
Esound (ESD)

Donde al probar la segunda no suena nada, y la última traba la ventana. Las otras funcionan bien. Al pasar el ratón sobre la primera sale:
Esto probará los siguientes dispositivos y usará el primero que funcione: (en inglés)
ALSA: x-phonon:CARD=0,DEV=0
ALSA: plughw:CARD=0,DEV=0
OSS: /dev/audio
OSS: /dev/dsp

lspci | grep -i vga
01:00.0 VGA compatible controller: ATI Technologies Inc RV770 LE [Radeon HD 4800 Series]
glxinfo | grep direct
direct rendering: Yes

Estoy usando el driver ATI Catalyst 9.6, instalado según estas instrucciones (al pie de la letra):
http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#Instal...

Observaciones: Dual-boot con Windows 7, aunque ahí no tengo música así que no he probado si ahí pasa (pero creo que no...)
En otras compus con tarjetas Gigabyte con sonido Realtek, he visto, en Windows XP, que a veces "El ratón suena"...
En esta máquina, al arrancar, se escucha bastante ruido de fondo en las bocinas hasta que el sistema (Linux o Win) entra, entonces se acaba el ruido, supongo que cuando ha cargado el controlador del dispositivo. También, las bocinas "truenan" con cosas como que se eche a andar el refri (un PEM, supongo), o a veces el teléfono inalámbrico (Interferencia EM)...

Lo que pasa es que sí tengo sonido, y si no muevo nada, suenan bastante bien mis canciones... Los juegos tienen sonido... todo había funcionado bien, salvo esto... bueno, y que al ejecutar cualquier aplicación wine obtengo

fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer

Y ahora recientemente me he dado cuenta que durante y después de ejecutar amarok, los videos de youtube no suenan, pero me parece que si no ejecuto amarok, sí suenan, porque cuando instale el flashplugin probé que hubiera sonido (Y al principio no, pero se solucionó subiéndole al PCM)...

La cuestión es que no sé por donde va el asunto. Por ahí dicen que podría borrar todo lo que tuviera que ver con pulseaudio, o también podría instalar todo lo que tenga que ver con pulseaudio. Yo opté por lo segundo, aunque no instalé libpulse-mainloop-glib0, ni libsdl1.2debian-pulseaudio...

Sin embargo, me molesta más lo de la interferencia de Firefox con Amarok. Incluso puedo hacer scrolling para arriba y para abajo contínuamente, y escuchar como si el cantante tartamudeara...

¿Hay forma de arreglar ésto? ¿Será cosa del Driver de ATI? ¿Tendrá que ver con el plugin de flash? ¿Tendrá que ver con eso de que algunas tarjetas de Intel HD no funcionan bien de "default"? ¿Será la manufactura de la tarjeta? ¿Será pulseaudio, o alsa? ¿Será firefox? ¿Será GTK en combinación con cualquiera de las otras cosas?

Por probar:
*Si se repite con un Mouse USB, porque ahora uso uno PS/2, esto podría descartar cuestiones de interferencia de hardware...
*Purgar todo lo que tenga que ver con pulseaudio
*Aprender que es eso de ALSA (Advanced Linux Sound Architecture), como se configura, etc, de lo cual yo ni idea...
*Desinstalar el flash y tal vez instalar el de 64 bits de la página de adobe
*Probar si se repite en el "Minefield" (firefox-3.5)
*Si ocurre en otras aplicaciones gnome...

Sugerencias, críticas, propuestas de linchamiento por lo largo del tema, se agradecen!
Soluciones, se reciben con extremo agradecimiento...

Saludos!

Este tema no debería estar aquí, debería estar en "Ejemplos de cómo solicitar ayuda en el foro" ( http://www.kubuntu-es.org/wiki/comenzando/ejemplos-solicitar-ayuda-foro ) (de hecho acabo de agregar un enlace a este tema e iré agregando más conforme los encuentre).

muy bien Stranger1712 clap


Mi estimado, acorde a mi experiencia yo me inclino a pensar que el problema está relacionado con el controlador de la tarjeta gráfica. Creo que tiene que ver con eso porque al momento de desplazar las páginas web Firefox comentas que se escucha el ruido, el cual debe ser ocasionado porque el sistema está re-dibujando la pantalla línea por línea, usando de manera inadecuada el procesador y la memoria, esto debe ser por la frecuencia de barrido la cual se mide en Herzios (Hz).

Si tienes una resolución, por ejemplo, de 1024x768@60, quiere decir que está trabajando a 60 Hz para hacer el barrido de la pantalla, intenta cambiar el valor en tu archivo /etc/X11/xorg.conf , para saber qué valores soporta tu sistema puedes usar el comando xrandr:

$ xrandr
Screen 0: minimum 320 x 240, current 1152 x 864, maximum 1152 x 864
default connected 1152x864+0+0 0mm x 0mm
   1152x864       75.0*
   1024x768       75.0     60.0     70.0
   800x600        75.0     72.0     60.0     56.0     65.0
   640x480        75.0     73.0     60.0
   896x672        60.0
   960x600        60.0
   832x624        75.0
   840x525        60.0
   700x525        75.0     70.0     60.0
   640x512        75.0     60.0
   720x450        60.0
   720x400        70.0
   640x400        60.0
   576x432        75.0
   640x384        60.0
   512x384        75.0     70.0     60.0
   416x312        75.0
   400x300        75.0     72.0     60.0     56.0
   320x240        75.0     73.0     60.0

Observa que en mi caso la resolución 800x600 soporta varias frecuencias de barrido: 75.0, 72.0, 60.0, 56.0, 65.0. La que tiene el asterisco (*) indica mi configuración actual.

También puedes intentar configurar una opción de Firefox: Editar> Preferencias> Avanzadas> General> Navegación> y desactiva/activa la opción "Desplazamiento suave" y prueba con ambas.

Es lo que por lo pronto se me ocurre.

Orale, gracias Siddharta!

Pero me temo que no ha funcionado...
Cambié la frecuencia del monitor a 75 Hz en el ATI Catalyst, lo comprobé en el menú del monitor y en efecto la frecuencia estaba cambiada, y el problema persistió. (este era uno de los modos soportados).
Habilité y deshabilité el Desplazamiento Suave y tampoco se solucionó.
Probé tambien empezando primero Amarok y después Firefox y viceversa, y también empezando primero o después la reproducción y tampoco sirvió.
Lo que sí noté es que hay un par de canciones que no sufren de el problema o resulta más difícil reproducirlo. Sin embargo no les encuentro características especiales, fallan en formatos tanto mp3, ogg y wma... (algunas canciones son del tiempo de cuando usaba el Windows Media para extraer la música de los discos)
La interrupción ocurre al hacer scrolling con la rueda del ratón y al mover la barra de desplazamiento. No hay interferencia al escribir, pero sí llega a ocurrir cuando hago click en un botón o hiperenlace. Además, una característica de este problema es que no pasa el 100% de veces, con ciertas canciones pasa "casi" siempre que hago scrolling, y en otras cuesta trabajo obtener una interrupción.

Probé con Adobe Reader, y no hay problemas al hacer scrolling ni seleccionando texto, probé en el Gimp y no hay problemas al hacer zoom o desplazarse por la imágen (Supongo que lo más parecido al "scrolling").
Probé el "Bleed Browser"(Minefield 3.5 Web Browser) que al abrirse titula la ventana como "Shiretoko" y que al ver en ayuda>acerca de Shiretoko, dice Mozilla Firefox for Ubuntu Canonical.. Shiretoko/3.5.1pre, y el error es idéntico al del firefox 3.0.11.

El único otro caso en que ocurre algo parecido es cuando subo y bajo el volúmen con los atajos del teclado, se escucha un pst que dura una décima de segundo...

En lo que escribo este post, se me ha ocurrido apagar los efectos de escritorio, y no me ha sido posible reproducir el problema. (ni con subir/bajar volúmen)
Sin embargo, los efectos del escritorio por sí mismos no me producen interferencia, ni el cubo ni las ventanas ni alternar los programas ni nada de eso...

Ahora he activado los efectos, y el problema se reproduce...

Supongo que esto significa que está relacionado con los efectos... O sea que "algo" tiene que ver la aceleración o el kwin...

Así que supongo que "deshabilitar los efectos" se puede considerar una "solución parcial"... (Pero no creo que pueda marcarse como solucionado, cierto?)

Más sugerencias se agradecen!

¡Gracias nuevamente!
¡Saludos!


strange1712 escribió:

[...] Lo que sí noté es que hay un par de canciones que no sufren de el problema o resulta más difícil reproducirlo. Sin embargo no les encuentro características especiales, fallan en formatos tanto mp3, ogg y wma... (algunas canciones son del tiempo de cuando usaba el Windows Media para extraer la música de los discos) [...]

Eso quizás esté relacionado con la Tasa de Transferencia (bit rate) con la que fue codificado cada archivo. Hay dos tipos de codificación: tasa de transferencia constante (Constant Bit Rate, CBR) y tasa de transferencia variable (Variable Bit Rate, VBR).

Por ejemplo, cuando se codifica un archivo de audio usando la opción CBR y un bit rate de 128 Kbps quiere decir que todo el archivo, en cada segundo de la pieza de audio, contendrá 128,000 bits de datos. Así que durante la reproducción, cada segundo de la pieza, siempre estará transmitiendo 128,000 bits sin variación alguna, será constante.

Por otro lado, cuando se utiliza la opción VBR entonces el programa codificador irá variando la tasa de transferencia durante la melodía, aumentando o disminuyendo la cantidad de bit rate según sea necesario acorde a la pieza .... es decir, quizás haya una parte de la melodía donde se oigan unos suaves violines iniciando una pieza, entonces el programa detectará la cantidad de audio y bajará la tasa a unos 128 Kbps (por ejemplo, puede ser menor/mayor), y de repente suenan los trombones, platillos, batería, piano, guitarra, y un gong chino, todos al mismo tiempo, así que el programa codificador, al detectar el aumento en la cantidad de audio aumentará la tasa a 256 Kbps (por ejemplo, puede ser mayor/menor), y momentos después vuelve a bajar y nuevamente a subir. Así que realmente tú no controlas el bit rate, sino el programa codificador. Por lo tanto cuando reproduzcas el audio tu programa reproductor podría mostrarte en su pantalla que el bit rate cambia como si estuviera loco, y no es que esté descompuesto, es que te está mostrando el VBR de cada momento de la pieza.

Es probable que tus archivos de audio estén todos con VBR y por eso notas esas interrupciones cuando el sistema requiere más uso del procesador. Es posible que sólamente los pocos archivos que mencionas estén con CBR y por eso, sin importar lo que hagas en el equipo, el sistema siempre está usando la cantidad requerida de procesador y memoria para mantener una reproducción constante.

Así que revisa las Propiedades de cada archivo de audio, especialmente de los que has observado diferencias, y compara en una hoja de papel, ve anotando cuáles están con CBR y cuáles están con VBR y luego reproduce, haz pruebas y compara. Quizás sea necesario cambiar todos a VBR o a CBR dependiendo de cuál te funcionó mejor.

Creo que es un buen momento para comentar lo siguiente: la razón por la cual se puede modificar la tasa de transferencia (bit rate) no sólamente está relacionada con la calidad del audio ni con el tamaño final que ocupará el archivo en un medio de almacenamiento. También está relacionada directamente con el uso que se hará de un medio de transferencia un una red. Así que si tenemos un archivo de audio de 128 Kbps compartido en una carpeta, y desde otro equipo de la red abrimos el archivo y lo reproducimos entonces en la red se estarán usando 128 Kbps del total de la capacidad que tenga el medio. Es por ello que el desempeño de la red en las oficinas de trabajo se ralentiza cuando alguien está escuchando horas y horas de música desde otro equipo, porque el reproductor está acelerando o disminuyendo la cantidad de datos (bit rate) con cada pieza, algunas veces bajará si el archivo en cuestión es de 64 Kbps, y otras veces se disparará si el archivo es de 352 Kbps y así todo el día, hasta que alguien vaya y le de un coscorrón al usuario latoso. Los usuarios creen que no afectan en nada porque dicen -"no estoy guardando nada en mi equipo"-, la realidad es que hubiera sido menor la afectación si hubieran copiado 1 GB de archivos mp3 en 10 minutos y luego los reproducen, en vez de estar 10 horas escuchando música desde otro equipo. Es por lo anterior que en los archivos de audio el concepto usado es bit rate.

Es erróneo cuando en las redes de computadoras las personas dicen "ancho de banda" porque el ancho de banda se usa cuando hablamos de señales analógicas, y se usa el Herzio (Hz) para medir la señal. Cuando se habla de redes de computadoras estamos hablando de señales digitales, y se usa el bit per second (bps) para medir la señal. Pero bueno, esa es otro historia.

Sidd.

Creo que sí tiene que ver con que el sistema se satura de alguna forma al tener los efectos activados. Me temo que no sé como averiguar si mis archivos son de bitrate variable (Y nunca he visto que la descripción de tasa de bits varíe, según el cuadro que sale en "editar información de la pista", los archivos son de 128 bps en su mayoría), pero he seguido probando y he descubierto que también ocurren interrupciones cuando minimizo o maximizo ventanas, o paso por encima de los plasmoids del escritorio, estando activados los efectos. Deshabilitando estos, no ocurren fallas. Instalé Juk y el problema resultó idéntico al de Amarok. Luego, probé instalando el songbird, pero la versión de los repositorios de Kubuntu no funcionó (que no encontraba "input-selector" y que checara GStreamer, cosa que hice e instalé casi todo lo que venía en el gstreamer, incluyendo los plugins del bueno, el malo y el feo {¿Es broma?}), así que bajé el ejecutable de la página de songbird, y aunque tenía los efectos activados, la reproducción no se veía afectada (¡El error no ocurre en Songbird!).

Pensando que podría tener que ver el tipo de librerías de los programas (Pensando que QT4, xmms o no se que, no está muy optimizado para trabajar con los 4 núcleos ó bien, el driver ATI de la tarjeta de gráficos es Demasiado acaparador de CPU), instalé el Rhytmbox, y tras instalar algunos codecs y ser invitado a comprar fluendo (Cosa que no hice), y terminar instalando el gstreamer-plugin-bad en lugar del bad-multiverse, y que me desinstalara no sé que de fluendo, descubrí que el Rhytmbox tiene peores problemas, al hacer scrolling o minimizar la aplicación, la música se puede detener por varios segundos en lo que reanuda... (Con Rhytmbox el problema se multiplica decenas de veces...)
A partir de ese momento mi sistema quedó medio trabado, el Kickoff tardaba segundos en aparecer, la ventana del navegador se minimizaba y maximizaba lentamente, y al volver a ejecutar Songbird, ahora sí se interrumpía la música.

Luego, sigo sin saber que ondas... Me parece que "algo" anda mal en la forma en que el sistema está usando los recursos, como que no distribuye bien la carga entre los procesadores y también se me figura que están entrando en conflicto los "servidores de sonido", aunque de eso no entiendo mucho. Es como si para "destacar" un Widget, o hacer un scrolling, el sistema le pidiera prestado al reproductor el CPU (Los 4) y se lo devolviera después... ¿Qué eso no lo debería hacer la GPU, procesar los efectos gráficos?

Probaré leyendo sobre las opciones del driver gráfico en el xorg.conf, a lo mejor algo tiene que ver con eso...
Por cierto que lo copiaré aquí por si alguien pudiera observar en él "algo" que pudiera estar causando esto...

$cat /etc/X11/xorg.conf

Section "ServerLayout"                        
        Identifier     "aticonfig Layout"     
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection                                       

Section "Files"
EndSection    

Section "Module"
EndSection     

Section "ServerFlags"
        Option      "Xinerama" "off"
        Option      "DontZap" "False"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "UseFastTLS" "2"
        Option      "TexturedVideo" "on"
        Option      "VideoOverlay" "off"
        Option      "XaaNoOffscreenPixmaps" "true"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Saludos, y gracias!

Hola!
Estoy pensando en que tal vez se debería cerrar esto porque parece que a final de cuentas el problema es el controlador de video ATI Catalyst, que aún no funciona muy bien y hace que el procesador consuma muchos recursos cuando están activados los efectos del escritorio.
Gracias a Siddharta y a quienes se preocuparon leyendo esto...
Ojalá pronto este tipo de cosas se mejoren en posteriores versiones del controlador. (Y el soporte de aceleración 2D)
Saludos!

Jeje... creo que hasta podría tener que ver con el hardware... Ahora estoy en Win7 x64 con los drivers bien instalados (Catalyst 9.6, Driver de sonido de Realtek incluido con Windows), y en realidad aparecen ligeros ruiditos al pasar el ratón por los widgets y al hacer scrolling, pero parece que sólo la primera vez, es decir, despés de haber pasado una vez ya no suena... y no se interrumpe el sonido, sólo aparece un ruidito muy ligerito... como una mosca pasando rápidamente.
Es decir, que no es tan molesto como en Linux, pero definitivamente hay algo en común.
Y no había probado en Win porque no había podido instalar el ex2fsd por eso de los controladores no firmados... pero ya pude, y así pude acceder a la música y comprobar esto. Aunque también lo comprobé con los archivos de muestra del win, así que tampoco es mi biblioteca...
En fín... sigo sin saber si esto ya se puede considerar solucionado...
Buenas noches!

Mejor no lo marques como SOLUCIONADO porque aún no tiene solución aún cuando creas que es cosa del hardware. De esta manera otros usuarios que tengan el mismo problema podrán saber que esto se ha quedado así sin haber podido ir más allá.

¡Saludos!

Hola, a mi me pasa algo parecido tengo una HD 4870.

No paran las interferecnias y eso fue hoy, ayer iba perfecto, creo que es porque se caliente demasiado la gráfica, reinicie el sistema y no me entro mas en kubuntu (se reinicia constatemente), entre en windows y también tenía interferencias. Apague el equipo, espere a que se enfriara y no volvió a entrar en kubuntu (mañana lo miraré, es muy tarde), pero sin embargo en windows no se oyen interferencias.. sin duda es muy extraño y seguramente sea cosa de la gráfica, no tenía otra a mano para probar... sé que ésta serie viene con tarjeta de sonido integrada, pero no sé si eso tendrá que ver...

Si a alguien le pasa algo parecido o encuentra una solución que lo diga por favor, gracias.

Después de todo este tiempo, parece que por fin el problema se ha solucionado instalando el Controlador de la tarjeta de sonido para esta máquina de la página de Realtek:

http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=14&PFi...

Viene con un archivo README que hay que seguir, y lo único diferente es que el archivo que dice que debe editarse no es

/etc/modules.conf

Sino

/etc/modprobe.d/alsa-base.conf

Quiero hacer notar que el chipset de audio de mi tarjeta madre era un "Codec de sonido Realtek ALC889A de 8 canales", pero alsa decía

aplay -l

**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: SB [HDA ATI SB], dispositivo 0: ALC883 Analog [ALC883 Analog]
Subdispositivos: 0/1
Subdispositivo #0: subdevice #0
tarjeta 0: SB [HDA ATI SB], dispositivo 1: ALC883 Digital [ALC883 Digital]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: HDMI [HDA ATI HDMI], dispositivo 3: ATI HDMI [ATI HDMI]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0

Lo cual estaba mal (es más vieja o sencilla, parece), y tras instalar los controladores, voilá!

aplay -l

**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: SB [HDA ATI SB], dispositivo 0: ALC889A Analog [ALC889A Analog]
Subdispositivos: 0/1
Subdispositivo #0: subdevice #0
tarjeta 0: SB [HDA ATI SB], dispositivo 1: ALC889A Digital [ALC889A Digital]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: HDMI [HDA ATI HDMI], dispositivo 3: ATI HDMI [ATI HDMI]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0

Y el sonido a mi parecer es mejor, y desaparecieron todas las interferencias.

Por ende, marco como Solucionado

MUCHÍSIMAS GRACIAS, SIDD!

Anthares, podrías probar si en tu caso el hacer algo parecido te soluciona el problema.

Saludos!