google earth se ve blanco cuando me acerco [Solucionado]

Primero de todo gracias por vuestro tiempo y segundo tengo que decir que cuando conecto google earth en el portatil y me acerco a la ciudad esta se convierte en blanco yo creo que es tema de grafica y he hecho lscpi y me sale Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07). Segun he leido por ahi si edito sudo gedit /etc/X11/xorg.conf
tendria que añadir a
Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

con añadir esto
Section "Device"
Identifier "Configured Video "
Driver "intel"
Option "UseFBDev" "true"
EndSection

estaría resuelto el tema?Es que me da un poco de repelus hacerlo asi de buenas a primeras
Gracias

Y si, lo mas probable es que sea un tema de la gráfica.
Primero haces un backup del xorg.conf (busca en el buscador del foro que se ha dicho muchas veces como) y luego lo modificas y guardas los cambios. También busca como restaurar el xorg.conf desde consola por si luego de reiniciar no logras entrar en modo gráfico.

Mas que "añadir", sería "reemplazar" esto:

Section "Device"
Identifier "Configured Video Device"
EndSection

Por esto:

Section "Device"
Identifier "Configured Video Device"
Driver "intel"
Option "UseFBDev" "true"
EndSection

Por supuesto si ya tienes instalado los drivers "intel".

Proba desactivando la atmósfera del google earth: 1. Accede al menú Ver 2. Quita la marca de la opción "Atmósfera".

He optado por la solución de pabloncs y tengo que decir que funciona a la perfeccion. Supongo que la primera solucion también funciona pero por el momento voy a lo facil.Tema resuelto mil y una gracias.
PD. Para poner tema solucionado que lo pone el moderador?por que yo lo intente pero decia que había pasado el plazo

Clic en la imagen para ver un video de como marcar un hilo solucionado:
Marcar hilo solucionado

gracias