actualizar klamav [Solucionado]

Mirad qué me sale cuando intento actualizar el KlamAv:

¿Significa algo que deba tener en cuenta?.

Yo normalmente no lo actualizo ya que el proceso es automático, sólo verifico que la barra de estado diga: "signatures up to date" , ese mensaje que muestras me aparece más bien algunas ocasiones cuando cierro Klamav.

A mí me aparece al iniciar.

He actualizado clamav por konsola porque no me ha permitido actualizar Klamav. Pensaba que ya quedaría actualizado también pero hace cosas raras. Debe ser que no tiene mucha utilidad un antivirus en Linux y los desarrolladores lo tienen un poco abandonado.

Lo desinstalaré y paso del tema. Gracias, siddharta.

Creo que no deberias dar por cerrado el tema, osea sino encontraste solucion dejalo abierto porque en realidad no encontraste que era lo que pasaba ni como arreglar el problema.

No me gustaria estar buscando solucion al mismo problema y ver este hilo y entrar todo emocionado para ver que no tenia solucion alguna jejejejeje.

en realidad klamav es un frontend de clamav, si actualizas clamav klamav está actualizado, luego el problema si que está resuelto....

Por lo que encontre este error es muy comun, en lo que vi decian que era un error que se producia cuando se instalaba kclamv que era una version difernte a clamv, segun decia tenian que ser la misma version los 2 sino dba ese error

No, no es que sean diferentes versiones, sino como dijo shaola: klamav es un frontend de KDE para el demonio clamav, por lo tanto al instalar klamav automáticamente se instala clamav.

Yo se que es un frontend, sino que decian que el problema era cuando no coincidia la version de clamv y kclamv, has de cuenta el tener el clamv desactualizado y un kclamv como frontend actualizado osea muchas opciones mas que las que realmente existen en la version de clamv que se tiene instalada, a eso me referia.

Ahhh, ok, ya entiendo lo que comentaste, pues realmente nunca he tenido problemas con klamav, siempre pongo así en la instalación y automáticamente instala las dependencias adecuadas:

sudo aptitude install klamav

Quizás nuestra amiga usó otra forma de instalar.

Saludos.

Si no venía ya instalado en kubuntu, es probable que utilizara Synaptic. Creo recordar que busqué Klamav + clamav y el sistema ya añadió las dependencias necesarias. Digo que es probable porque Synaptic era mi instalador favorito en Ubuntu cuando aún no había aprendido los comandos básicos del terminal.

Sin embargo, ahora he lanzado tu comando y me sigue saliendo el aviso al abrir Klamav.

Quizás lo recomendable sea depurar y reinstalar:

a) iniciar sesión con privilegios de superusuario:

sudo su

b) desinstalar Klamav:

aptitude remove klamav

c) purgar archivos que pudieran quedar:

aptitude purge klamav

d) actualizar las listas de paquetes de los repositorios:

aptitude update

e) instalar klamav y sus dependencias:

aptitude install klamav

f) finalizar sesión con privilegios:

exit