Ayuda con geforce4 420 go [Solucionado]

Hola

Mi problema es el siguiente:
Tengo una Laptop Toshiba con una tarjeta de video nvidia geforce4 420 go(ya esta viejita) donde instale Kubuntu 8.10, y mi problema es que cada vez que activo el controlador de mi tarjeta, al reiniciar me aparece una pantalla parpadeante mitad blanca mitad negra y no aparece la pantalla de login, quiero comentar que ya lei varios de los posts similares en este foro y otros y realice lo que en ellos dice, ya lo intente con envy y me pone resoluciones muy chicas (la maxima de 800x600) tal vez estoy haciendo algo mal, en una pagina encontre un aporte para instalar tarjetas nvidia pero meciona que esta hecho sobre ubuntu 7.04 y en uno de los puntos menciona la siguiente linea

$ aptitude install linux-headers-2.6.20.16-generic

Lo que no se si deba hacerlo ya que imagino que correponde al Ubuntu 7.04 y quiero comentar que lo intente sustituyendo el 20.16 por 27.11 que aparece al iniciar el grub, y al final me dio un error diciendo que no se pudo instalar el controlador.

Yo se que este es un tema muy comentado, pero se los agradecere por la ayuda que me pudioran prestar.

hola yo tambien he tenido muchos problemas con esta grafica

tengo un Toshiba S2450-101 con GeForce4 420 Go

yo lo tuve que instalar con Envyng en instalar Nvidia driver el que vale es la version 96.43.09
los problemas que tuve es que al reiniciar se quedaba la pantalla en negro aunque arranca ubuntu perfectamente no se ve el escritorio.
creo que es porque habria que instalar con las X cerradas pero bueno yo lo que hice fue instalarlo de nuevo en modo
texto arrancando el PC con la opcion Recovery Mode (sin que arranque el escritorio) y tecleando envyng -t y funciona perfectemente

ojo yo tengo en este PC Ubuntu 8.10 no Kubuntu pero creo que te deveria valer igual.

Yo en el portátil con esa gráfica tengo kubuntu 8.04, instalé los drivers con envy y me funcionaron bien a la primera, manda reiniciar tras instalarlos, sale el logo de nvidia y arranca con aceleración. Por si te sirve de ayuda.

Saludos

Gracias por sus aportes ya logre solucionar mi problema, dicen que el que busca encuentra, y yo encontre mi solucion en un foro en ingles por lo que tuve que agarrar un tumbaburros ingles-español y me puse a arrastrar el lápiz, aqui comparto la solucion por si le sirve a alguien, no sin antes dar los creditos a la persona que lo aporto en su idioma original, (disculpas pero no tuve la precaucion de anotar su nombre).

El error al parecer es porque la salida de la tarjeta grafica no reconoce la pantalla de la laptop y lo toma como monitor CRT

1. Kmenu-Sistema-Administrador de Hardware
- Habilitar Nvidia acelerador de graficos y confirmar los cambios
2. Reiniciar el equipo, aparecera la pantalla parpadeante en blanco y negro
3. Presionar Ctrl+Alt+F1 para abrir Terminal, escribes tu Login
4. Como usuario root tecleas sudo nano /etc/X11/xorg.conf para editar el archivo.
5. Encuentra la seccion "Device" y al final(antes de EndSection) insertas la siguiente linea
Option "UseDisplayDevice" "DFP-0"
6. Guardas los cambios y cierras el archivo
7. Reinicias el servidor X tecleando sudo /etc/init.d/kdm restart

Ahora hay que checar la resolucion de la pantalla, en mi caso presentaba 969x768 y yo queria 1024x768, si este es el caso tenemos entonces que corregir el EDID (Extended Display Identification Data), y aqui los pasos.

8. Abrir Terminal y escribir
sudo apt-get install nvidia-settings ghex read-edid

9. Ahora obtenemos los datos del EDID

  • Ir a Kmenu-Sistema-NVIDIA X Server Setting
  • Da un click donde dice "DFP-0 -(Nvidia Default Flat Panel)
  • Click en el boton "Aquire EDID"
  • Guardar el archivo "edid.bin" en el Escritorio y OK
  • Cerramos la ventana NVIDIA X Server settings

10. Ahora necesitamos checar los datos del EDID
En Terminal activamos el directorio Escritorio
cd ~/Escritorio

Checamos la resolucion en el EDID
parse-edid edid.bin | grep "Mode"

Te mostrara algo como esto:
parse-edid: parse-edid version 1.4.1
parse-edid: EDID checksum passed.
Mode "969x768" # vfreq 60.004Hz, hfreq 48.363kHz

Como observamos la resolucion no es la correcta (en mi caso) esta resolucion esta en el archivo EDID como valor HEXADECIMAL, por lo que necesitamos corregirlo de la siguiente manera:

1. Mantenemos abierta la Terminal y vamos al Kmenu-Desarrollo-Hex Editor
2. En el editor hexadecimal seleccionamos abrir y buscamos el archivo edid.bin aceptamos.

Ahora bien, la siguiente pantalla nos muestra una serie de datos en parejas de caracteres hexadecimales, cada par corresponde a un byte, el numero de pares por fila puede variar. Ahora nosotros necesitamos cambiar la resolucion horizontal, el primer digito es guardado en el como el primer caracter del byte 58 y los dos ultimos digitos se guardan en el byte 56, en nuestro caso el numero 969 en valor hexadecimal es representado por 3C9 (puedes checarlo con una calculadora cientifica), para no hacer mas largo este intento de guia, busca una linea como la siguiente: (el valor Hex 3C9 esta en negritas)

01 01 01 64 19 C9 77 31 00 26 30 4F 88 36 00 42 FF

Ahora que sabemos lo anterior vamos a cambiar los valores del byte 56 (C9) y 58(31). convirtiendo a Hex el valor de 1024 (resolucion buscada) nos da igual a 400, por lo que debemos sustituir en el byte 56 la C9 por 00 y en el byte 58 el 3 por el 4 (el 1 lo dejamos igual), con lo que nuestra linea debera quedar asi:

01 01 01 64 19 00 77 41 00 26 30 4F 88 36 00 42 FF

Una vez hecho los cambios, cerramos el archivo y regresamos a la Terminal.
con el la flecha de cursor hacia arriba volvemos a ejecutar parse-edid y nos dara lo siguiente:
parse-edid: parse-edid version 1.4.1
parse-edid: EDID checksum failed - data is corrupt, Continuing anyway
Mode "1024x768" # vfreq 57.64Hz, hfreq 46.462kHz

No te preocupes por el checksum failed, no es importante, ahora copiamos el archivo "edid.bin" al directorio de las X para que nos lea el EDID correcto.

1. Copiamos edid.bin en /etc/X11/
sudo cp edid.bin /etc/x11/
2. Editamos xorg.conf para corregir EDID (sugiero hacerlo como root para que nos acepte los cambios)
nano /etc/X11/xorg.conf
3. En la seccion "Screen" insertamos la siguiente linea:
Option "CustomEDID" "DFP-0:/etc/X11/edid.bin"
4. Guardamos los cambios y reiniciamos la computadora.
5. En caso de que al reiniciar te presente otra resolucion como en mi caso "800x600" abres preferencias del sistema y en pantalla podras ver que ya tienes la resolucion de "1024x768" solo hay que seleccionarla.

Ojala me haya sabido explicar, y le sirva a otros, de cualquier manera cualquier duda con mi explicacion, con mucho gusto se las aclaro.

Saludos desde Chihuahua, Mx.

Estopendo, gracias por el aporte